Link Properties dialogue fields not initialized

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: mcornall, Assigned: cmanske)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; I; Linux 2.2.14 i686)
BuildID:    2000040708

When the "Link Properties" dialogue is opened for an existing link, the "Link
text" and "Link to" fields are blank (the dialogue box does display the values,
but *above* the fields).

Reproducible: Always
Steps to Reproduce:
1. Open an existing page in Composer.
2. Click on an existing link.
3. Click on the LINK icon to bring up the properties.

Actual Results:  The "Link text" and "Link to" fields are blank.

Expected Results:  The "Link text" and "Link to" fields should contain the
current values for that link.

This problem did *not* occur in Milestone 14. In M14, the "Link to" field was
properly initialized.

Note: There was no "Link text" field in M14, so obviously the dialogue box has
been redesigned (I like the change, BTW. It fixes something that always annoyed
me in Netscape 4.x).

Comment 1

19 years ago
Charley...
Hopefully this will be addressed when the dialogs are rewritten.
Assignee: beppe → cmanske
(Assignee)

Comment 2

19 years ago
It seems to work just fine in my current debug build, when the caret or 
selection is anywhere inside the link text.
Do you have a specific page + link that you see this happening?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → M16
(Reporter)

Comment 3

19 years ago
Okay, now I'm confused. Last Saturday, when I discovered that M14, and 040708,
seemed to work differently, I went back and forth, starting and stopping each
one a number of times, and I'd swear that 040708 worked the way I described,
every time.

Now, I can't seem to repeat the problem, no matter what I try.

I can't think of anything I've done that would have changed things. I didn't
reinstall 040708, I don't remember changing the configuration, and I haven't
installed any new software. I run it using "./mozilla" in the package directory
where it was unzipped/untarred. I rebooted in between, but I can't see why that
would make a difference. I experimented with the Enlightenment window manager in
between (I normally run ICE with Gnome support), but since Enlightenment was
already installed and configured, I can't see why it would change things to try
it then switch back. Besides, doesn't Mozilla create its own widgets, rather
than relying on the window manager to do so?

I'm sure I saw a Link Properties dialogue that had an input field for "Link
text", as well as "Link to". I'm sure that I'm not confusing it with the Link
Create dialogue, because the only thing I was trying to do at the time,
repeatedly, was to fix a broken link. But now I'm starting to wonder if I'm
crazy (it's not the first time :). Is there an experimental dialogue in the code
that I might have been triggering? Are there any intermittent bugs in XUL that
would cause it to display the wrong dialogue box?

Either way, unless I can repeat the problem, it looks like you should put this
one on hold. Thanks for checking.
(Assignee)

Comment 4

19 years ago
Ok.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 5

19 years ago
verified in 4/11 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.