Moving search engines up and down does not work right

RESOLVED FIXED in Firefox 2

Status

()

Firefox
Search
P1
normal
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: alex, Assigned: Gavin)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2
fixed1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

Today I added some search engines, and removed some of the default. When i tried to rearrange the order my search engines after clicking OK the search engines were not ordered in the way i wanted them. Finally after moving an engine which resulted in moving an entirely different one i managed to order them in the way i want

Reproducible: Always

Steps to Reproduce:
1.Add some search engines
2.Remove some (of the default?) search engines
3.Move a search engine
4.Click OK and go see how the engines are ordered

Actual Results:  
The engines are not ordered in "manage search engines"

Expected Results:  
The engines should be ordered in the way in "manage search engines"
Steps to reproduce:
1) Add an engine (any engine)
2) Delete all engines other than Google and the added engine
3) Try to move Google below the added engine

This happens because the engine manager does not take into account "hidden" engines when finding the old/new index for the move.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Version: unspecified → 2.0 Branch
Assignee: nobody → gavin.sharp
Flags: blocking-firefox2?
Priority: -- → P1
Target Milestone: --- → Firefox 2
Status: NEW → ASSIGNED

Updated

11 years ago
Flags: blocking-firefox2? → blocking-firefox2+
Created attachment 238128 [details] [diff] [review]
patch
Attachment #238128 - Flags: review?

Updated

11 years ago
Attachment #238128 - Flags: review? → review+

Updated

11 years ago
Whiteboard: [has patch][checkin needed]
mozilla/browser/components/search/nsSearchService.js 	1.83
mozilla/browser/components/search/nsIBrowserSearchService.idl 	1.16
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][checkin needed] → [needs approval]
Comment on attachment 238128 [details] [diff] [review]
patch

This is a low risk patch that only affects search engine ordering. The indices passed by the engine manager were based on the visible engine list, while the search service treated the incoming index as though it was based on the list of all engines (including hidden engines). This patch fixes that discrepancy so that ordering works correctly when you have a hidden default engine.
Attachment #238128 - Flags: approval1.8.1?

Updated

11 years ago
Whiteboard: [needs approval] → [has patch][needs approval]

Comment 5

11 years ago
Comment on attachment 238128 [details] [diff] [review]
patch

a=schrep for 181drivers
Attachment #238128 - Flags: approval1.8.1? → approval1.8.1+
mozilla/browser/components/search/nsIBrowserSearchService.idl 	1.1.2.17
mozilla/browser/components/search/nsSearchService.js 	1.1.2.67
Keywords: fixed1.8.1
Whiteboard: [has patch][needs approval]
You need to log in before you can comment on or make changes to this bug.