CSS fixed position element border display bug

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: corpus-deus, Unassigned)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

When displaying en element that's of "position: fixed;" with a border AND the page is high enough to require scrolling - there's a glitch with the right hand border; it seems to create a "ghost" line that scrolls with the background and is only erased when it goes off the top or bottom of the screen.

Reproducible: Always




No error appears in the W3C css or markup validators and the glitch doesn't occur in MSIE7 beta or Opera 9. View http://www.xenotaph.net/firefox_border_bug.html in either of those browsers to view the expected results.
Confirming with Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.8.1b2) Gecko/2006091004 BonEcho/2.0b2
Status: UNCONFIRMED → NEW
Component: General → Layout: Block and Inline
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout.block-and-inline
Hardware: PC → All
Version: unspecified → 1.8 Branch
I actually see ghost lines from the bottom border, though.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060911 Minefield/3.0a1 - Build ID: 2006091104

Can't see this in either the trunk build or the latest branch build either.

-- Ryan

Comment 4

12 years ago
WFM, no ghosting.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060910 BonEcho/2.0b2
(Reporter)

Comment 5

12 years ago
Just checked this on my home PC running:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

and I get exactly the same results... although it's the same Firefox build running the same OS so that's not entirely surprising.

I notice though, that although I'm using the latest pre-compiled build of Firefox revision 1.8.0.6 - looking at the rv numbers of other people testing - it looks as though it might be resolved in versions 1.8.1b2+, for Windows compiles at least.

Comment 6

12 years ago
Firefox 2.0b2 on Linux: the right border is occasionally 2px when resizing
the window width. Same for bottom border when resizing height.

This was fixed on trunk between builds: 2006-01-25-05 -- 2006-01-26-04
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-01-25+04%3A00&maxdate=2006-01-26+05%3A00&cvsroot=%2Fcvsroot
Likely fixed by bug 317375

-> WORKSFORME
Severity: normal → minor
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 7

12 years ago
On my PC: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

This problem is still present. I haven't been able to reproduce it on a simpler page, but the "trails" or ghost lines effect can be seen on the following pages:

http://www.mnot.net/cache_docs/ - For this page, it is only visible on a particular <pre> element. Scroll down and after you pass this text ("Typical HTTP 1.1 response headers might look like this:"), the <pre> shows ghost lines from the border of the fixed position element at the bottom.

http://raffles.awardspace.com/G/misc/ - For this page, hover over "settings", choose "custom" from the dropdown and then enter 5 in the input box and submit. The problem is seen with the link that says "NEXT" on the right when you scroll up only. Before scrolling, note that the bottom border is 2px when it is supposed to be 1px.

Oddly enough, the first page also displays this issue in Firefox 1.0.8 but the second page does now.
You need to log in before you can comment on or make changes to this bug.