Closed Bug 352143 Opened 16 years ago Closed 7 years ago

Command-Shift-[ and ] should switch tabs.

Categories

(Firefox :: Keyboard Navigation, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: web, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

The Command-Shift-[ and ] should shift tabs (in the same way as Command-Option-Left Arrow and Right Arrow do) for consistency with Safari.

Reproducible: Always

Steps to Reproduce:
1. Open multiple tabs.
2. Follow a link in the current tab.
3. Press Command-Shift-[.

Actual Results:  
The browser goes back to the previous page displayed in the tab.

Expected Results:  
The browser should shift to the tab to the left, circling around to the right end if the leftmost tab was selected.
Clarification - the intent here is for the Shift modifier to apply the action to tabs, rather than pages (cmd-[ and cmd-] affect page navigation).

Safari makes this Shift distinction.

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
One more vote for this bug. Should be a small improvement to make it consistent with Safari.
Work for me in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0. Does it work for you?
Mostly works, but Command-Shift-[ and Command-Shift-] do not work if web content has focus like a Google Spreadsheet.
Ryan, it's probably due to Google Spreadsheets insisting on handling the keypress itself. Webapps are allowed to cancel the default behavior of most keyboard shortcuts:(

In any case, it's a separate thing from this bug; this should have been closed long time ago.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Not worth filing a new bug? Did you try to reproduce? It's more than spreadsheets.
Ryan, not sure. I can reproduce, but as I said, I guess it's due to specific pages interfering with the shortcuts. Myself I use Cmd+opt+left/right, which usually works.

If I'm right, bug 1052569 proposes to forbid overriding some shortcuts, and the question is just making sure this particular shortcut is on the list.

If I'm wrong and there's something else going on, someone will have to first figure out what, and create a minimal testcase for the problem. In my experience just filing a bug about a bad interaction between a complex website and Firefox doesn't usually get much attention.. I see you have a @mozilla.com address, perhaps you can ask the right people personally.
You need to log in before you can comment on or make changes to this bug.