Bug 352251 (é)

Mac floating accent characters ignored

RESOLVED DUPLICATE of bug 347041

Status

()

RESOLVED DUPLICATE of bug 347041
12 years ago
8 months ago

People

(Reporter: lorrlil, Unassigned)

Tracking

({qawanted})

2.0 Branch
PowerPC
Mac OS X
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

Firefox 2.0 beta 2, when inputting Macintosh floating accent characters into a text window (such as this one) at any site, such as option-e or option-i, they are completely ignored. This is not a problem in Firefox 1.5.x for Mac -- has been introduced in Firefox 2.0.

Reproducible: Always

Steps to Reproduce:
1. Connect to any site
2. Click into a text entry window.
3. Try to enter a character such as an "o" with circumflex accent. Press option-i to start this process, the floating accent does not appear on screen. Then press the letter "o" and just a plain "o" is displayed, no accent.

Actual Results:  
Floating accent keystrokes are ignored.

Expected Results:  
Should see the floating accent character on screen. Then when you type the letter, it should display as accented.

There is no workaround other than to copy and paste the accented character from another program.

I'm using Noia eXtreme theme -- the version that is compatible with Firefox 2.0, 3.23 -- and Adblock extension.

Comment 1

12 years ago
Simon, is this possibly fallout from your access key handling changes?
Keywords: qawanted
Version: unspecified → 2.0 Branch

Comment 2

12 years ago
I doubt it. The accesskey handling code on Mac should only kick in when the Ctrl key (and no other modifier) is pressed. I'm unfortunately not able to verify this, since I haven't got access to a Mac (FWIW: under Windows this WFM).

Comment 3

12 years ago
That works correctly on my side.
FWIW those 'floating characters' never appear on screen before you finished inputting the whole character (accent + o in the example). In any app.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060911 BonEcho/2.0b2 ID:2006091101

OS X 10.4.7 PPC

Comment 4

12 years ago
I get the accent with an score on option+i , then the accent over the "ô" when I type the o.  Same build and OS as phillippe. I've never messed with any keyboard settings on this machine so it would be the default.

Comment 5

12 years ago
I can confirm this bug on 2.0RC1.  When I type option-e followed by another e, nothing happens.  Using another application (tested on BBEdit and Word) when I type option-e, I see a floating accent. When I type another e, I get a single accented é.

The only way that I could get an accented é in a firefox text input or textarea was to copy and paste it.

Comment 6

12 years ago
Ok, this is strange. Accents have started working for me and the ONLY change that I have made to my setup is installing the Web Developer Extension.  Yesterday I could not type an é. Now I can.  
Alias: é
This is probably a dupe of bug 347041.
People seeing this - can you confirm that it starts happening after visiting a page with Java on it?

Comment 8

12 years ago
Yes, that was exactly it. é worked. I visited a java applet and é stopped working.  I reproduced this three separate times with three separate java applets in 2.0RC1. 

*** This bug has been marked as a duplicate of 347041 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Depends on: 1091954

Updated

4 years ago
No longer depends on: 1091954

Updated

10 months ago
Blocks: 1323083

Updated

8 months ago
No longer blocks: 1323083
You need to log in before you can comment on or make changes to this bug.