Minor design glitches in tab bar

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Peter 'vt100' Schwindt, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
When moving over one of the close buttons in the tab bar, the button gets resized 1 px too large...

See attached jpg
(Reporter)

Comment 1

12 years ago
Created attachment 237933 [details]
screenshot snippet of the 1px too large close button
(Reporter)

Comment 2

12 years ago
Unfortunately I forgot: Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/2006091104 BonEcho/2.0b2

Sorry for spamming
this is only when mousing over?  i haven't seen this yet.

peter / myk, do you guys see this?

Comment 4

12 years ago
I can't reproduce this particular bug on any font size I try.

I have seen extensions that mess with close buttons cause things like this before (Tab Mix Plus et. al).
I can't reproduce this behavior.  I tested in Ubuntu 6.06 (Dapper Drake) with GNOME and the default Human theme.  I tried to reproduce the conditions in the screenshot: some tabs, but not enough to completely fill the tab bar.  The rightmost tab showing the problem.  The following page loaded into it:

http://weblogs.mozillazine.org/asa/archives/2006/09/newer_firefox_t.html

I tested at font sizes 8, 9, 10, 11, 12, 13, 14, 16, and 18.  I tested regular, hover, and active states with the rightmost tab being the selected tab, and I also tried those states with some other tab being selected.  I also tested other tabs.

I did see a similar problem with the labels in the tabs at 13px and up.  I filed that as bug 352729.

I note that the bookmarks toolbar in the screenshot looks like it has some native styling applied to it.  Could this have something to do with a GNOME or Firefox theme being applied?
(Reporter)

Comment 6

12 years ago
There's no special theme applied to FF, only the default 2.0 one. I might check with some really fresh profile, if this could help
(Reporter)

Comment 7

12 years ago
Ok, I tried again with a freshly created profile using Gecko/2006092114 BonEcho/2.0

---> Still a problem.

How do we continue? Blocker?

Comment 8

12 years ago
(In reply to comment #7)
> Ok, I tried again with a freshly created profile using Gecko/2006092114
> BonEcho/2.0
> 
> ---> Still a problem.

Hmm.  Can you give your Font face/size and DPI?  Also the particular window manager (and version) and theme you're using?  Maybe it's some combination of all of those that causes this.
(Reporter)

Comment 9

12 years ago
WM is openbox with ayunb theme

Resolution is 1280x1024 (on two screens), so it's virtually 2560 by 1024

Default fonts as follows:

Serif (16) - serif - sans-serif - monospace (12); no minimum font size

Encoding is western (8859-1)

(Distribution: Debian/sid, Xorg 7.0.23)
(Reporter)

Comment 10

12 years ago
I'll close this one, haven't seen any problem for some months...
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.