Round-trip change with unary operator in parens

RESOLVED DUPLICATE of bug 461269

Status

()

Core
JavaScript Engine
--
minor
RESOLVED DUPLICATE of bug 461269
12 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
PowerPC
Mac OS X
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
js> function() { return 2 * (~3) }
function () {
    return 2 * -4;
}

js> function () {
    return 2 * -4;
}
function () {
    return -8;
}
(Reporter)

Updated

11 years ago
Depends on: 373672
Current tracemonkey tip:

js> function() { return 2 * (~3) }
function () {
    return -8;
}
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 461269
You need to log in before you can comment on or make changes to this bug.