<link rel="stylesheet" type="text/css" href="" > calls the document url instead of doing nothing

RESOLVED DUPLICATE of bug 300601

Status

()

RESOLVED DUPLICATE of bug 300601
12 years ago
12 years ago

People

(Reporter: jricard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

In a html document, if a stylesheet is attached by a link with an empty url in the href attribute, Firefox loads the same page instead of loading nothing. Therefore the page is called again from the server :-\

Reproducible: Always

Steps to Reproduce:
1. create a doc with <link rel="stylesheet" type="text/css" href="" > 
2. open the document
3. watch the live http headers

Actual Results:  
the doc has been called 2 times

Expected Results:  
the empty link 

do not load the stylesheet since the url is empty

*** This bug has been marked as a duplicate of 300601 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.