Adblock 0.5.3.043 shows compatible with Firefox 2.0b2 but is not.

VERIFIED DUPLICATE of bug 313071

Status

--
trivial
VERIFIED DUPLICATE of bug 313071
12 years ago
3 years ago

People

(Reporter: bc, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
https://addons.mozilla.org/firefox/10/ says 	Firefox  	0.7 - 2.0b2  	ALL but install.rdf says

        <!-- FireFox -->
        <em:targetApplication>
                <Description>
                <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
                <em:minVersion>0.7</em:minVersion>
                <em:maxVersion>2.0a3</em:maxVersion>
                </Description>
        </em:targetApplication>
  
How is the version range on the add-ons page created? If this is a common problem, it should be populated from automatically inspecting the install.rdf when the new xpis are released.

Comment 1

12 years ago
The version shown on the a.m.o page can be edited by the developer after upload. The EM should be picking up the new info via its default updateURL.

Duping to the bug that requests we repackage XPIs when this happens.

*** This bug has been marked as a duplicate of 313071 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 2

12 years ago
This system is employed so that if the developer tests their add-on with a newer version and finds it to work correctly, they can edit the compatibility info via the developer control panel instead of having to upload and release a new version of their add-on. On install, the app automatically queries AMO for this compatibility info.

So yeah, by design.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

12 years ago
The reason I filed this bug is that I found the restart button disabled after testing adblock and filed a bug on that. That bug was duped to another bug where incompatible extensions caused the restart button to be disabled. 

I had thought that since amo said that it was compatible with 2.0b2 that the bug was more general however it appears that regardless of what amo told the extension manager, it tickled the bug.

It just seems bogus that I need to unzip the extension to actually see what versions it really thinks are compatible. whatever.
Component: Add-ons → Administration
QA Contact: add-ons → administration
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.