Update wizard sometimes flashes a large textbox (really, a blank xul:browser) when showing the details for a minor update

RESOLVED FIXED

Status

()

--
minor
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

({regression})

1.8 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-02-27])

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b2) Gecko/20060911 BonEcho/2.0b2

When I the update page loads (after clicking "check for updates"), there's a flash of what looks like a large textbox.

STR:

1. Wait until there's an update
2. Open Help/Check for Updates...

Expected Results: No flash of a big textbox.
Is this a dupe of bug 350490?
not sure if it is a dup.  if it looks like a large textbox, it must be the xul:browser that is used for loading details, but that is only for major updates.

is this a recent problem, or has it been happening for a while.

dietrich, anything special about your profile, like lots of extensions?
Assignee: nobody → sspitzer
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> not sure if it is a dup.  if it looks like a large textbox, it must be the
> xul:browser that is used for loading details, but that is only for major
> updates.
> 
> is this a recent problem, or has it been happening for a while.

the 9/11 build is the first time i'd noticed it.

> dietrich, anything special about your profile, like lots of extensions?
> 

20+ extensions, with about half of them disabled.
> the 9/11 build is the first time i'd noticed it.

thanks for that info.  the checkins to the update code don't point to anything immediately (see http://bonsai.mozilla.org/cvsquery.cgi?branch=MOZILLA_1_8_BRANCH&file=mozilla/toolkit/mozapps/update/&date=week)

> 20+ extensions, with about half of them disabled.

interesting.  as with bug #350490, having lots of extensions could make things worse as it could delay the processing time.
Status: NEW → ASSIGNED
dietrich, do you still see this?
(Reporter)

Comment 6

12 years ago
I updated a few times today, branch and trunk for both mac and win, and did not notice this again. Were there any recent changes that might've affected this?
> Were there any recent changes that might've affected this?

none that I can think of, but looking at the code, it seems like a good idea for me to move the "detailsDeck.selectedIndex = 1;" to the end of onShowMoreDetails().

I mentioned this back in https://bugzilla.mozilla.org/show_bug.cgi?id=350490#c5, but forgot about it, and failed to do it for FF2.
Created attachment 239521 [details]
screen shot, if I hack a "return" into onShowMoreDetails()
dietrich, does that last screen shot resemble what you saw?  (I hope so!)

I can reproduce what I think is the problem if I do this:

 onShowMoreDetails: function() {
   var detailsDeck = document.getElementById("detailsDeck");
   detailsDeck.selectedIndex = 1;

+  return; // hack!

so, I think by moving "detailsDeck.selectedIndex = 1;" to the end of onShowMoreDetails(), I can avoid this problem.

What the user would see (after I make this change), if they ran into this bug, is your new UI from bug #352675:  the throbber and the "Checking if this update will cause problems with your extensions and/or themes..." text.
(Reporter)

Comment 11

12 years ago
Comment on attachment 239526 [details] [diff] [review]
patch

(In reply to comment #9)
> dietrich, does that last screen shot resemble what you saw?  (I hope so!)
> 

yeah, that's probably what i saw. i could reproduce it w/ my daily profile (lots o' extensions) in today's branch build.

r=me on the patch.
Attachment #239526 - Flags: review?(dietrich) → review+
drivers:  If possible, could this be a ride along if we do a FF2 RC2?  Here's why I think we want this.

for 2.0, the detailsDeck is new.  For slower machines, it appears possible that users will see the flash of the <xul:browser> when we have minor updates.

this low risk fix will prevent that flash.

Flags: blocking-firefox2?
Whiteboard: [hoping for a FF2 RC2 ride along. drivers, please see comment #12]
> i could reproduce it w/ my daily profile

just to clarify:  could or could not?
dietrich, thanks for the prompt review.  I'm going to get this on the trunk first, and then beg drivers to let me ride along for FF2 RC2 (if there is one.)
Summary: Update page flashes a textbox when loading → Update page flashes a large textbox (really, a blank xul:browser) when showing the details for a minor update
(Reporter)

Comment 15

12 years ago
(In reply to comment #13)
> > i could reproduce it w/ my daily profile
> 
> just to clarify:  could or could not?
> 

*could* 

I saw the flash when updating to today's branch nightly.
fix checked into the trunk, setting tm to ff3a1, but hoping drivers let me backport the fix to the branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 alpha1
OS: Mac OS X 10.3 → All
Hardware: PC → All
since the detailsDeck and the <license> xul:browser are new, this is a regression.
Keywords: regression
Whiteboard: [hoping for a FF2 RC2 ride along. drivers, please see comment #12] → [hoping for [rc ridealong]. drivers, please see comment #12]

Comment 18

12 years ago
Seth - yeah lets get this for 181RC2.
Comment on attachment 239526 [details] [diff] [review]
patch

Requesting approval1.8.1, as per comment #18.
Attachment #239526 - Flags: approval1.8.1?
Target Milestone: Firefox 3 alpha1 → Firefox 2

Comment 20

12 years ago
Comment on attachment 239526 [details] [diff] [review]
patch

Approved for RC2.
Attachment #239526 - Flags: approval1.8.1? → approval1.8.1+
Whiteboard: [hoping for [rc ridealong]. drivers, please see comment #12] → [rc ridealong][checkin needed (1.8 branch)]
schrep: thanks for the ride along approval.

fix landed on the branch.

this is something we can verify on the nightlies, as on the nightly update channel we provide minor updates.

dietrich, since you were seeing this, can you keep an eye out for it?  You'll need one update to get the fix, and then after that, you should see the improvement.
Flags: blocking-firefox2?
Keywords: fixed1.8.1
Whiteboard: [rc ridealong][checkin needed (1.8 branch)] → [rc ridealong]
> dietrich, since you were seeing this, can you keep an eye out for it?

darn, I just saw it on Mac OS X when getting the minor update for tbird.  I was running tbird 2 beta 1 (20060930), which is built from the MOZILLA_1_8_BRANCH.

I saw the large text box / blank xul:browser flash by.  It was a very small update, perhaps that could be part of the trick to reproduce this issue.

re-opening and clearing keywords.

note, I haven't seen this on windows yet.
Status: RESOLVED → REOPENED
Keywords: fixed1.8.1
Resolution: FIXED → ---
Summary: Update page flashes a large textbox (really, a blank xul:browser) when showing the details for a minor update → Update wizard sometimes flashes a large textbox (really, a blank xul:browser) when showing the details for a minor update
Whiteboard: [rc ridealong]
Target Milestone: Firefox 2 → ---
sorry for the bug spam, re-assigning bugs back to default owner if I'm not working actively on them.
Assignee: sspitzer → nobody
Status: REOPENED → NEW
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Updated

9 years ago
Whiteboard: fixed?

Comment 24

9 years ago
is there any reason to believe this still exists, besides comment 22?
Dietrich, are you still able to reproduce?
Whiteboard: fixed? → [closeme 2010-02-27]
Closing per whiteboard closeme date since no reply to last comment/fix has already landed on m-c.
Status: NEW → RESOLVED
Last Resolved: 12 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.