Closed Bug 352433 Opened 14 years ago Closed 13 years ago

"all day" is shown on "print" view and printed product for an event selected "All Day"

Categories

(Calendar :: Printing, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bengb, Assigned: martinschroeder)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Avant Browser; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: 0.3+2

"all day" is shown on "print" view and printed product for an event selected "All Day".  This is unnecessary as person printing calendar (Sunbird) already will know if an event is all day or not.  This is different than needing to be reminded about a time for an appointment/meeting.  I am talking about such things as "Birthdays", "Anniversarys", certain days to pay bills, etc...

Reproducible: Always

Steps to Reproduce:
1.select event as All Day
2. select monthly grid for layout and see "all day"
3.  Print with monthly grid selected for layout and see "all day"



Expected Results:  
leave 'all day" off for events selected as All Day
Confirmed.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061031 Calendar/0.4a1
Changing to New state as per koen's comment on the Oct. 31st test day.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 373289
Assignee: nobody → mschroeder
OS: Windows XP → All
Hardware: PC → All
Status: NEW → ASSIGNED
Attached patch Patch v1Splinter Review
Unlabeled all-day events have to be reevaluated when we also want to print tasks (without start and end date). I removed the now unused AllDay string from dateFormat.properties.
Attachment #265539 - Flags: review?(daniel.boelzle)
Attachment #265539 - Flags: review?(daniel.boelzle) → review+
Whiteboard: [checkin needed after 0.5]
patch checked in on trunk and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed after 0.5]
Target Milestone: --- → 0.7
Depends on: 386639
This check-in regressed Bug 386639.
Duplicate of this bug: 389204
You need to log in before you can comment on or make changes to this bug.