Last Comment Bug 352439 - Reference leaks in modutil
: Reference leaks in modutil
Status: RESOLVED FIXED
:
Product: NSS
Classification: Components
Component: Tools (show other bugs)
: 3.11.3
: All All
: P2 normal (vote)
: 3.12
Assigned To: Julien Pierre
: Slavomir Katuscak
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 18:53 PDT by Julien Pierre
Modified: 2006-09-15 16:10 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Call SECMOD_DestroyModule where needed (7.44 KB, patch)
2006-09-12 18:54 PDT, Julien Pierre
alvolkov.bgs: review+
Details | Diff | Review

Description Julien Pierre 2006-09-12 18:53:43 PDT
Running some modutil commands, I ran into many assertions due to reference leaks on shutdown with NSS_STRICT_SHUTDOWN enabled (which I always have in my .cshrc). They are caused by some calls to SECMOD_FindModule without a corresponding SECMOD_DestroyModule . Patch forthcoming .
Comment 1 Julien Pierre 2006-09-12 18:54:50 PDT
Created attachment 238122 [details] [diff] [review]
Call SECMOD_DestroyModule where needed
Comment 2 Julien Pierre 2006-09-12 18:57:21 PDT
More testing is needed in this area. We don't test the list, rawlist, enable, set default, unset default options of modutil in all.sh .
Comment 3 Alexei Volkov 2006-09-15 15:46:06 PDT
Comment on attachment 238122 [details] [diff] [review]
Call SECMOD_DestroyModule where needed

r=alexei.volkov
Comment 4 Julien Pierre 2006-09-15 16:10:33 PDT
Checking in pk11.c;
/cvsroot/mozilla/security/nss/cmd/modutil/pk11.c,v  <--  pk11.c
new revision: 1.23; previous revision: 1.22
done

Note You need to log in before you can comment on or make changes to this bug.