If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

PDF Attachments Corrupt

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Todd, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Thunderbird version 1.5.0.5 (20060719)

I receive faxes via efax as PDF attachments.  Adobe Reader says the file is damaged and could not be repaired, and the byte size if I save the attachments is a lot smaller than the uncorrupted file.  My email is on an IMAP server and has a filter applied to move it to a separate folder.  The attachment is correct if I view it in Outlook.

Reproducible: Always

Steps to Reproduce:
1.Try to open a PDF attachment from eFax

Comment 1

11 years ago
I have a similar problem. in 1.5.0.7 and 1.5.0.8, I cannot attach pdf documents to the emails I send: they are always corrupt. However, I can receive and open pdf documents as attachments.
(Reporter)

Comment 2

11 years ago
This appears to be a more general bug now -- any larger attachments appear to be truncated.  I have reproduced the problem with PDF's, Word documents, and JPG images.  In all cases, opening the email in Outlook allows me to retrieve the attachments.

Comment 3

11 years ago
My problem is similar to Todd's and I'm using Thunderbird 1.5.0.8.  When I download the PDF attachment, the downloaded file size is the same as the original, but Acrobat reports: "There was an error opening this document.  The file is damaged and could not be repaired."  When I have multiple PDF attachments, one will typically be okay, but the rest are corrupt.  I can log in to my email account from the vendor's webmail access and download the attachment and everything is just fine with it.  It's only when it gets into Thunderbird that the corruption presents itself.  I can recreate this problem all of the time.  I can send more info if needed, just let me know what I need to send.  

Comment 4

11 years ago
i to have the same problem add one more even my word docs is corrupted in thunderbird if save it also it throws an error saying there was an error opening document i open webmail and check everything is fine and opens without any problem. please help me to resolve this problem.

Comment 5

11 years ago
I have the same problem. Today I have switched to Thunderbird 2.0. The problem continues. The size of saved PDF file is a little bit larger. (I can decode attachment from the saved EML file using Total commander and receive correct file). So the problem is in the decoding procedure.

Comment 6

10 years ago
It looks like Thunderbird has an IMAP attachment corruption problem.  These
appear to be related to the same bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=390795
https://bugzilla.mozilla.org/show_bug.cgi?id=352581
https://bugzilla.mozilla.org/show_bug.cgi?id=301541

http://groups.google.com/group/Gmail-Problem-solving/browse_thread/thread/28f5c7328725fa6e/67f95b8605703a48?hide_quotes=no 
(Reporter)

Comment 7

10 years ago
I haven't seen this in recent versions of Thunderbird.  Also, when I was seeing it, I found that I could fix the attachments by exiting Thunderbird, deleting the message file, and restarting Thunderbird.  That forced a reload of the attachment(s).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.