Lack of Sunbird Add-ons page on amo

VERIFIED FIXED

Status

VERIFIED FIXED
12 years ago
3 years ago

People

(Reporter: omarb.public, Assigned: mattwillis)

Tracking

Details

(URL)

Attachments

(4 attachments, 6 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060913 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060913 BonEcho/2.0b2

I tried to find an extension/ theme for sunbird and I selected 'get extensions/themes' from 'Addons'. It opened https://addons.mozilla.org/sunbird/extensions/
and
https://addons.mozilla.org/sunbird/themes/
The extensions/themes were not compatible with sunbird.
What did happen with:
https://addons.mozilla.org/extensions.php?app=%7B718e30fb-e89b-41dd-9da7-e25a45638b28%7D
?

Reproducible: Always
The problem is that addons.mozilla.org doesn't know how to handle Sunbird at the moment.

The 'Get Extension' links calls 
[http://en-us.add-ons.mozilla.com/en-US/sunbird/0.3a2+/extensions/]
that is redirected to
[https://addons.mozilla.org/sunbird/extensions/]

But addons.mozilla.org will only display Firefox extension/themes.
(Assignee)

Comment 2

12 years ago
I was supposed to file a bug on this anyway.

We'd like the "Get More" stuff link in Sunbird's add-ons manager to at least land on something that says Sunbird.

If we could do it before 0.3 ships, that'd be spiffy.
Severity: minor → normal
Status: UNCONFIRMED → NEW
Component: General → Public Pages
Ever confirmed: true
OS: Windows XP → All
Product: Calendar → addons.mozilla.org
Hardware: PC → All
Summary: Get extensions/themes link to wrong site → Lack of Sunbird Add-ons page on amo
QA Contact: general → web-ui

Comment 3

12 years ago
Please, what version of Sunbird are you using? I have: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060507 Mozilla Sunbird/0.3a2 
and that points me at 
https://addons.mozilla.org/extensions.php?app=%7b718e30fb-e89b-41dd-9da7-e25a45638b28%7d 
and https://addons.mozilla.org/themes.php?app=%7b718e30fb-e89b-41dd-9da7-e25a45638b28%7d 
These show Sunbird extensions, although no Sunbird themes (kinda useless to upload them atm, unless they're also compatible with Fx, Tb or the suite, because of an existing bug.)

Unfortunately, all of the AMO development is now focussed on Remora (AMO 3) - we acknowledge that the v1 devCP and v2 public site have many bugs and shortcomings, but similar to a Firefox code freeze, we're shortly going to be only accepting security/stability fixes, or anything else that has an urgent reason to be checked in. 

We're currently about to get SeaMonkey support happening - it'll appear in the search filter box, add-ons which are compatible with SeaMonkey will show the SeaMonkey icon and version compatibility, and add-ons which are SeaMonkey only will actually be installable (they aren't currently!)) - but this plan does not include urls with /seamonkey/ in them (AFAIK,) or a SeaMonkey banner image, or adding "SeaMonkey Add-ons" to the footer of the site. This is planned to be one of the last things we change on the site.

I don't know what urls SeaMonkey should (or does) point at, presumably https://addons.mozilla.org/extensions.php?app=GUID and https://addons.mozilla.org/themes.php?app=GUID would still work... but I thought the plan was to move all app strings to locale.service.mozilla.com/other/stuff/ or something similar, and then redirect from there to the location that makes the most sense, and it's easier to change that redirection at a later date, rather than wait for the next release of the app.

So what I'm thinking, is that if we clarify what version of Sunbird you're using and why yours is pointing at http://en-us.add-ons.mozilla.com and mine isn't, we can get the redirection stuff on mozilla.com to point at the above urls that I mentioned with the Sunbird GUID, instead of "sunbird" and that'll work temporarily.

If, yes, IF, the Seamonkey support goes ahead (it might not yet) and works, and doesn't cause any ugly bugs, it's possible (only POSSIBLE) that we may do the same for Sunbird. (See the above list of SeaMonkey-related changes for reference.) 
I don't want to give you guys too much hope, because as I said before, development is focussed on Remora, but I'm just outlining how stuff is atm. Also, I use Sunbird and think it's great, and I don't use Seamonkey ;)

Remora is under heavy development and all available cycles are needed for that. The next bad news is that initially, Remora is planned to be Firefox only :( So if we don't get Sunbird support in the existing AMO, we won't get it until some time after the release of Fx 2 (Fx 2 is the Remora deadline IIRC.) After the initial release, we'll continue to work on improving Remora, including multiple app support, etc.

As always with anything I say, it's just what I've picked up from around the place - Remora is very much in the planning/initial development stage, so lots of stuff above can change. 
(In reply to comment #3)
I'm using a nightly build of Sunbird 0.3 that we be released this month. (Hopefully!)

About two or three weeks ago the URLs were changed for all toolkit applications with Bug 348076 and Bug 350123. The new URLs are
[http://%LOCALE%.add-ons.mozilla.com/%LOCALE%/%APP%/%VERSION%/themes/] and 
[http://%LOCALE%.add-ons.mozilla.com/%LOCALE%/%APP%/%VERSION%/extensions/]
and are defined in
[http://lxr.mozilla.org/mozilla/source/toolkit/locales/en-US/chrome/mozapps/extensions/extensions.properties#35]
(Assignee)

Comment 5

12 years ago
Created attachment 239019 [details] [diff] [review]
Adds Sunbird to amo2

Adds support for Sunbird wherever I could find it necessary.
Icons to follow.

This will still need the SQL run on the db to make Sunbird a "supported" app.
Assignee: nobody → mattwillis
Status: NEW → ASSIGNED
Attachment #239019 - Flags: first-review?(shaver)
(Assignee)

Comment 6

12 years ago
Created attachment 239021 [details]
/mozilla/webtools/addons/public/htdocs/images/s-sunbird.png
Attachment #239021 - Flags: first-review?(shaver)
(Assignee)

Comment 7

12 years ago
Created attachment 239023 [details]
/mozilla/webtools/addons/public/htdocs/images/sunbird_icon.png
Attachment #239023 - Flags: first-review?(shaver)
(Assignee)

Comment 8

12 years ago
Created attachment 239024 [details]
/mozilla/webtools/addons/public/htdocs/images/switch-sb.gif
Attachment #239024 - Flags: first-review?(shaver)
(Assignee)

Comment 9

12 years ago
Created attachment 239026 [details]
/mozilla/webtools/addons/public/htdocs/images/title-sunbird.gif
Attachment #239026 - Flags: first-review?(shaver)
(Assignee)

Comment 10

12 years ago
Created attachment 239027 [details]
/mozilla/webtools/addons/public/htdocs/images/icons/sunbird.png
Attachment #239027 - Flags: first-review?(shaver)
Comment on attachment 239019 [details] [diff] [review]
Adds Sunbird to amo2

r-: I don't think Sunbird belongs in the footer of every page.
Attachment #239019 - Flags: first-review?(shaver) → first-review-
(Assignee)

Updated

12 years ago
Attachment #239021 - Flags: first-review?(shaver) → first-review?(fligtar)
(Assignee)

Updated

12 years ago
Attachment #239023 - Flags: first-review?(shaver) → first-review?(fligtar)
(Assignee)

Updated

12 years ago
Attachment #239024 - Flags: first-review?(shaver) → first-review?(fligtar)
(Assignee)

Updated

12 years ago
Attachment #239026 - Flags: first-review?(shaver) → first-review?(fligtar)
(Assignee)

Updated

12 years ago
Attachment #239027 - Flags: first-review?(shaver) → first-review?(fligtar)
(Assignee)

Comment 12

12 years ago
Created attachment 244176 [details] [diff] [review]
Adds Sunbird to amo2, but not to the footer

Doesn't add Sunbird to the footer per shaver's previous review comment
Attachment #239019 - Attachment is obsolete: true
Attachment #244176 - Flags: first-review?(fligtar)
Comment on attachment 239026 [details]
/mozilla/webtools/addons/public/htdocs/images/title-sunbird.gif

The banner image has to have a transparent background for it to display properly in the header.
Attachment #239026 - Flags: first-review?(fligtar) → first-review-
Comment on attachment 239024 [details]
/mozilla/webtools/addons/public/htdocs/images/switch-sb.gif

The switch icon isn't necessary if Sunbird won't be in the footer.
Attachment #239024 - Flags: first-review?(fligtar) → first-review-

Updated

12 years ago
Attachment #239023 - Flags: first-review?(fligtar) → first-review+
Comment on attachment 239021 [details]
/mozilla/webtools/addons/public/htdocs/images/s-sunbird.png

What is s-sunbird.png for?

Updated

12 years ago
Attachment #239027 - Flags: first-review?(fligtar) → first-review+
(Assignee)

Comment 16

12 years ago
Comment on attachment 239024 [details]
/mozilla/webtools/addons/public/htdocs/images/switch-sb.gif

Ya, this is no longer needed
Attachment #239024 - Attachment is obsolete: true
(Assignee)

Comment 17

12 years ago
Created attachment 244228 [details]
Title with transparency

Now transparent.
Attachment #239026 - Attachment is obsolete: true
Attachment #244228 - Flags: first-review?(fligtar)
(Assignee)

Comment 18

12 years ago
Comment on attachment 239021 [details]
/mozilla/webtools/addons/public/htdocs/images/s-sunbird.png

Not needed.
Attachment #239021 - Attachment is obsolete: true
Attachment #239021 - Flags: first-review?(fligtar)
Comment on attachment 244176 [details] [diff] [review]
Adds Sunbird to amo2, but not to the footer

Unfortunately, a bunch of these patch files got changed during the Fx2 reskinning. I updated the patch and added some necessary other items. I'll attach that updated patch in a minute.

You can see what this looks like here: https://update-staging.mozilla.org/~fligtar/v2/public/htdocs/sunbird

SQL to make supported:
UPDATE `applications` SET supported=1 WHERE AppName='Sunbird';

Please browse the above site and make sure everything is working as desired. I guess Sunbird doesn't have themes?

Also, we currently have no featured extensions that are Sunbird-compatible, which causes some major homepage layout problems. We would need to find one or several to make featured for Sunbird (I randomly picked one in the demo).
Attachment #244176 - Flags: first-review?(fligtar) → first-review-
Created attachment 244236 [details] [diff] [review]
Updated sunbird patch
Attachment #244176 - Attachment is obsolete: true

Comment 21

12 years ago
I don't think sunbird_icon.png properly matches the other icons - the others have some drop-shadow on them - is this intentional?

Also, if you recommend a sunbird add-on that also works with other apps, it shows up in the recommended list for those apps too (eg. minimise to tray will show up in the recommended list for all apps.)

(Assignee)

Comment 22

12 years ago
Created attachment 244257 [details]
sunbird_icon.png

Does this look better?
Attachment #239023 - Attachment is obsolete: true
Attachment #244257 - Flags: first-review?(fligtar)
Comment on attachment 244257 [details]
sunbird_icon.png

Yeah, looks better.
Attachment #244257 - Flags: first-review?(fligtar) → first-review+
(Assignee)

Updated

12 years ago
Attachment #244228 - Flags: first-review?(fligtar) → first-review+
(Assignee)

Comment 24

12 years ago
Looks good! Thanks

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 25

12 years ago
Great work! :-)
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.