Folder contents pane has garbage (overstruck, duplicated) characters

RESOLVED WONTFIX

Status

defect
--
major
RESOLVED WONTFIX
13 years ago
7 years ago

People

(Reporter: stugots, Unassigned)

Tracking

x86
Windows XP
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Workaround: https://bugzilla.mozilla.org/show_bug.cgi?id=352694#c44)

Attachments

(8 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060914 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060914 Minefield/3.0a1

This started recently when the new UI theme was introduced to the 1.8 nightlies.  It's still in the version 2 beta 1 (20060914) nightly.

The folder contents pane (the upper-right one in the default layout) often has garbage characters in the Subject, Sender, Date, and Size columns.  The garbage characters seem to be overwrites of column information for other rows in the pane, and they usually happen on alternate rows.

It happens most of the time, and I don't have to do anything to provoke it.  It happens in e-mail and RSS folder displays.

Sometimes it stops happening, but I do not know what I do to make it stop.  Some time later, it will start happening again, and I don't know what I do to make it re-occur, either.


Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird, click on Inbox to display folder contents.
2.
3.

Actual Results:  
I'll try to attached a .jpg of the results, if Bugzilla will let me.
(Reporter)

Comment 1

13 years ago
(Reporter)

Comment 2

13 years ago

Comment 3

13 years ago
Going to confirm this based on another report on mozillazine with this screenshot http://imageshack.us/?x=my6&myref=http://forums.mozillazine.org/viewtopic.php?p=2519451
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

13 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=354754

I think the problem is with the classic theme. If I use another theme, the messages are displayed correctly. However, with another theme, I feel the program react more slowly. 

And most important, this bug happen in Thunderbird 2.0 too.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061009 Thunderbird/2.0b1pre ID:2006100903

Comment 5

13 years ago
Requesting blocking 2.0 since this happens on branch also per comment 4
Flags: blocking-thunderbird2?
*** Bug 354754 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
reporter, is this still an issue with the recently released Beta:

http://www.mozilla.com/en-US/thunderbird/releases/2.0b1.html
(Reporter)

Comment 8

13 years ago
Yes.  I'm running the 20061213 Thunderbird 1.8 nightly, and it's still happening.

FWIW, other people have mentioned it in the MozillaZine forums.  E.g., http://forums.mozillazine.org/viewtopic.php?t=498791 .
I see this happen in TB and FF, see my bugs

350478 (TB)

353283 (FF)
(Reporter)

Comment 10

13 years ago
FYI, this still happens with the latest 1.8 nightly builds.

Comment 11

13 years ago
Not sure there's much we can do here. Could it be a graphics card interaction issue? Does changing the resolution or the # of colors help anything?
(Reporter)

Comment 12

13 years ago
That's a funny response.

This didn't start happening until the last theme change in Thunderbird.  It was whatever the theme changes was shortly before 9/14/06.  My bug report starts with, "This started recently when the new UI theme was introduced to the 1.8 nightlies."

I haven't changed any hardware on my system, so it's not a graphics card issue.  But just for yucks, I tried changing the resolution and color depth, and it doesn't make the problem go away.

Maybe the problem isn't Thunderbird per se, but the code in the new (new in 9/06) theme.
Scott, did you read https://bugzilla.mozilla.org/show_bug.cgi?id=350478 ?

An old Dell Notebook, Hardware and drivers did not change for 4 years now. In comment 5 I mention that TB 2 alpha1 was the last version without corrupt display. All nightlies since then show the issue. And similar goes for Firefox, btw. 

Seems very much like a change in the underlying base that affects (probably Theming) of both apps. 

Where ever there is a gradient in the Theme, it will show those artifacts sooner or later :(

Jens

Updated

13 years ago
Duplicate of this bug: 350478
(Reporter)

Comment 16

12 years ago
Another user has reported this problem.  See http://forums.mozillazine.org/viewtopic.php?t=520932 .
Duplicate of this bug: 377856
Duplicate of this bug: 378010

Comment 19

12 years ago
I'm also getting this bug; when I upgraded today from 1.5.x to Thunderbird 2.0.0.0 version (20070326) it started appearing.  It makes Thunderbird unusable; I'm going to have to rollback temporarily but am willing to test fixes.

I'm running Windows 2000 on a ~5-year old Dell Inspiron 8000 with 
all the latest Dell drivers, ie nVidia GeForce2 GO, v.44.25, A17.

I also started seeing intermittent overlapping text in Firefox tabs, over the last couple months, at some point which I can't quite define.  But that wasn't nearly as annoying or persistent.  I've also found that Acrobat 8 is giving me problems when I scroll a line at a time (scrolling a page at a time avoids the issue.)  It may be in part a graphics driver issue, but I can vouch for the fact that this was only exposed with newer versions of FF/TB/Acrobat using some new code path.  I've never seen it before the last wave of upgrades the last three months and I've been using FF/TB for years.

If someone can suggest a workaround (a third-party theme?) I'm game to try that too.
Duplicate of this bug: 378144
Duplicate of this bug: 378170

Comment 22

12 years ago
I have confirmed that switching themes is a viable workaround; I had luck using the second theme I tried, the Whitehart TB 2.0 theme (which lacks gradient fills as someone recommended in an earlier comment) at https://addons.mozilla.org/en-US/thunderbird/addon/3791 

Comment 23

12 years ago
Also experiencing this bug with tb 2.0's default theme. I started tb in safemode and the problem persisted. I am running Windows XP SP2. Similarly, I am experiencing Bug 354870, in Firefox which involves the tab strip show garbled graphics. I too was able to work around this bug by using another theme. 

Comment 24

12 years ago
The workaround with WhiteHeart theme has worked for me too.
(Reporter)

Comment 25

12 years ago
I feel dumb.

I'm running the 20070422 Firefox trunk and the 20070422 Thunderbird 1.8 trunk, a.k.a. 2.0.0.4pre.

In Thunderbird, I do a Tools | Add-ons, and in the pop-up I click on Get Themes.  In Firefox, I click on Whitehart.  Now I'm at https://addons.mozilla.org/en-US/thunderbird/addon/3791 .

I click Install Now. It's downloaded, and then I get an error pop-up saying:

  Whitehart TB 2.1 could not be installed because it is not compatible with Minefield.

This message is suboptimal, because as a user I don't have the faintest idea why a Thunderbird theme needs to be compatible with Firefox...

Help! How do I work around this?

Comment 26

12 years ago
I believe Firefox is trying to apply your Thunderbird Add-on to FireFox. And the WhiteHart email-only add-on doesn't work in Firefox of course. I dunno why there seems to be such a basic usability flaw for Firefox/Thunderbird add-ons.

In any case, the further workaround I discovered was that when I tried visiting that same URL in (eep) IE, it allowed me to download the .xpi file to my hard disk, and I was then able to install it from my hard disk from Thunderbird Tools | Add-ons directly.   YMMV.

Comment 27

12 years ago
John, just follow the instructions here: http://kb.mozillazine.org/Themes
(Reporter)

Comment 28

12 years ago
Greg W and Emerson, thanks for the hints.  The UX for loading Thunderbird themes definitely needs some work.  BUT I can confirm that the bug does not present itself with the Whitehart TB 2.1 theme on my machine, either.

Hooray!  (I do like the default TB theme better, but I can live with this! :) )

Comment 29

12 years ago
I have the same problem.

I have reverted to thunderbird 1.5 but I am also willing to test fixes.

I am also running on an old dell laptop (Inspiron 2650) with Windows XP SP2



Comment 30

12 years ago
This issue only started for me with the update to 2.0.0.0.  I also worked around it by applying a different theme, but in certain themes the garbled text also occurs in the folders list!

I am running Windows 2000 SP4 on an older Dell desktop.

Comment 31

12 years ago
Display settings change that will work around bug, allowing use of the default theme.

Comment 32

12 years ago
Theodore Kloba's display settings work-around works for me.

Mere coincidence that my display adapter is also an NVIDIA RIVA TNT2?

Comment 33

12 years ago
Does Firefox 2 have any issues showing say the book mark manager window for folks with graphic cards that are seeing this problem? I can't think of what our theme is doing in the thread pane and the folder pane that would cause this.

Updated

12 years ago
Blocks: 378635

Comment 34

12 years ago
Does anyone who has a graphics acceleration card that's seeing this also have a debug build where we can make changes to the theme one by one until we figure out why the graphics card is having problems?
Duplicate of this bug: 378817

Comment 36

12 years ago
My graphics card isn't an Nvidia Riva TNT... but it is an Nvidia GeForce2 Go, and Theodore Kloba's display settings work-around, reducing the graphics hardware acceleration one notch below "Full" in display properties, also worked for me.  The default theme now works.

Duplicate of this bug: 378912

Comment 38

12 years ago
Theodore Kloba's display settings work-around works for me too. Also, the overlapping text on Firefox tabs has gone away.

My graphics card is a NVidia TNT2 Model 64.

Comment 39

12 years ago
(In reply to comment #38)
> Theodore Kloba's display settings work-around works for me too. Also, the
> overlapping text on Firefox tabs has gone away.
> 
> My graphics card is a NVidia TNT2 Model 64.


So this problem with graphics cards effects Firefox too?

Comment 40

12 years ago
yep. (In reply to comment #39)
> (In reply to comment #38)
> > Theodore Kloba's display settings work-around works for me too. Also, the
> > overlapping text on Firefox tabs has gone away.
> > 
> > My graphics card is a NVidia TNT2 Model 64.
> 
> 
> So this problem with graphics cards effects Firefox too?
> 

yep, see this screenshot: https://bugzilla.mozilla.org/attachment.cgi?id=259556

it was attached to bug# 354870

Comment 41

12 years ago
I know it wouldn't be glamarous, but if a non developer wants to help us figure out what's going on, one could help by trying to figure out in which build this problem first showed up.

We store every nightly branch build at:

http://archive.mozilla.org/pub/thunderbird/nightly/

Directories containing thunderbird 2 based builds end in -mozilla1.8

Jens B. first reported this bug (see Bug 350478) on  2006-08-28, so we know the build located here has problems:
http://archive.mozilla.org/pub/thunderbird/nightly/2006-08-28-06-mozilla1.8/

Next we need to find a build where the problem is not present. A lot of the new theme changes landed in this build:
http://archive.mozilla.org/pub/thunderbird/nightly/2006-08-17-06-mozilla1.8/
So maybe try a build from before the 17th of August.

Once you have a build that works and one that doesn't start testing the nightly builds in between until we find the day the problem showed up. This will help us a lot in trying to figure out what caused this problem for folks!

Comment 42

12 years ago
If I was a betting man, I'd say this is caused by the background image the new theme uses for odd rows in the message list pane:
i.e. this style that was added on 08/15:

#threadTree treechildren::-moz-tree-row(odd) {
  background-image: url("chrome://messenger/skin/icons/row.png");
  background-position: bottom;
  background-repeat: repeat-x;
}

Comment 43

12 years ago
I tested half a dozen builds.  The issue doesn't happen on or before build:
  http://archive.mozilla.org/pub/thunderbird/nightly/2006-08-17-06-mozilla1.8/
and does happen starting at build:
  http://archive.mozilla.org/pub/thunderbird/nightly/2006-08-18-03-mozilla1.8/

Comment 44

12 years ago
Thanks Greg. Sure enough, that snippet for the background image for the threapane landed on the 17th on the 1.8.1 branch (not the 15th like I first reported).

In theory, we should be able to remove that style rule by adding the following to your userChrome.css file (http://www.mozilla.org/support/thunderbird/edit#css):

#threadTree treechildren::-moz-tree-row(odd) {
  background-image: none !important;
}

I bet that fixes the problem!

Comment 45

12 years ago
(In reply to comment #44)
> In theory, we should be able to remove that style rule by adding the following
> to your userChrome.css file
> (http://www.mozilla.org/support/thunderbird/edit#css):
> 
> #threadTree treechildren::-moz-tree-row(odd) {
>   background-image: none !important;
> }
> 
> I bet that fixes the problem!
This worked, although the background is a bit bland now. I also tried adding the above code into Firefox's userChrome.css file and this seemed to fix bug# 354870, without any side effects. 

Comment 46

12 years ago
I can confirm that Scott's fix in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=352694#c44">comment #44</a>, creating/modifying a userChrome.css file with that text also works around the problem for me.  

(Side-note: the mozilla.org instructions mentioned a userChrome-example.css file that I didn't find in my Thunderbird profile's chrome directory... but later found in my Firefox profile's chrome directory.  Just 3-line userChrome.css file worked fine though; the example file wasn't really needed.)  

Unlike the commenter in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=352694#c44">comment #45</a> though, I tried applying the same fix in Firefox's userChrome.css and it did not solve the tab overstrike issue.  (Which makes sense because "treechildren"/"tree-row"s would seem to be specific to Thunderbird, although I'd imagine theres an analogous Firefox fix.)

So we have three reports of Nvidia graphics cards with this issue, cards that are ~4-6 years old.  Does anyone else experiencing the bug want to document what graphics card and/or drivers they're using?

Comment 47

12 years ago
(In reply to comment #45)
> (In reply to comment #44)
> > In theory, we should be able to remove that style rule by adding the following
> > to your userChrome.css file
> > (http://www.mozilla.org/support/thunderbird/edit#css):
> > 
> > #threadTree treechildren::-moz-tree-row(odd) {
> >   background-image: none !important;
> > }
> > 
> > I bet that fixes the problem!
> I also tried adding
> the above code into Firefox's userChrome.css file and this seemed to fix bug#
> 354870, without any side effects. 
> 
After restarting my computer I began to see the bug# 354870 on Firefox again, so I guess the above fix did not also work for Firefox. 

My graphics card is a NVIDIA RIVA TNT2 Model 64/Model 64 Pro. Its probably from about 01-02.

Comment 48

12 years ago
Adobe Acrobat 8.x also has graphics drawing problems when "A Geforce 2 or TNT2 video card is installed in the machine.":
  http://www.adobe.com/go/kb400660 

(I have to fully-disable all graphics acceleration to solve those though, not just move the slider down a notch so the root cause may be slightly different.)

Comment 49

12 years ago
Same problem here, also the NVIDIA RIVA TNT2 model 64/ model 64 pro.
Theodore Kloba's display settings work-around worked also for me.
Despite other replies we never had this issue with previous Thunderbird versions but just showed up with the 2.0.0.0 release.
Even the work around works I hope a bugfix will be implemented.
(In reply to comment #46)
> So we have three reports of Nvidia graphics cards with this issue, cards that
> are ~4-6 years old.  Does anyone else experiencing the bug want to document
> what graphics card and/or drivers they're using?
I reported this problem for Thunderbird 2.0 in bug #378010, and I'm also using a laptop with a NVidia GeForce2 Go card. The problem doesn't show with thunderbird versions up to 1.5.0.10 neither on firefox.

Comment 51

12 years ago
I don't think we're going to remove the background image from the thread pane.

Maybe we can put together a 'hot fix' extension, put it on addons and link to it from the release notes for folks who are running into this using the older nvidia card so users that run into this can have a fix without having to add a userChrome.css file on their own.

Or the release notes could instruct the user to adjust their graphic acceleration settings which is probably simpler than having them download and install an extension.
(In reply to comment #50)
Adjusting the graphics card acceleration settings fixed the bug for me too. The used acceleration level is said to be used when having cursor or garbled pixmap problems by the help text in the control panel...

Comment 53

12 years ago
(In reply to comment #51)
> 
> Or the release notes could instruct the user to adjust their graphic
> acceleration settings which is probably simpler than having them download and
> install an extension.

Adjusting my graphic acceleration settings solve the problem partially. I have to restore the original configuration since some online videos played with Windows Media Player embedded on Firefox had poor quality image. The fix that worked for me was the replace of the Thunderbird theme.

Comment 54

12 years ago
Changing the hardware acceleration worked for me, but it'd be nice if we didn't have to do that. We didn't have to do it 1.5.x... what changed in 2.0.0.0 that would make us have to do this? 

Updated

12 years ago
Flags: blocking-thunderbird3?
Duplicate of this bug: 379748

Comment 56

12 years ago
I'm getting the same overwrites as displayed in the photos above.  Does anyone want / need screen prints of my Nvidia configuration?  (12 meg in rtf file)  I can reduce it if someone will tell me what they need

No other software has ever done this, doesn't seem like we should have to degrade a whole system.

Comment 57

12 years ago
My Notebook Dell Inspiron 8100 with W2k pro, Gforce2go, Driver NVIDIA 6.14.10.4482 show the same behavier.
The above workarounds solve the problem for me too, but in addition i recognize that the graphic refresh problem disappears, when JAVA is running in background!
For Example if I start the Java control panel there are no problems, the tabs in Firefox and the lines in Thunderbird are ok at the same time.

Updated

12 years ago
Flags: blocking-thunderbird2?

Comment 58

12 years ago
Just thought I'd say that I also had this problem on an older Dell with a NVIDIA RIVA TNT2 Model 64 .  The new theme solved the problem.

Comment 59

12 years ago
I contacted Dell customer support via their online chat and the person there said, mildly to my surprise, that if there was a confirmed graphics driver bug that Dell would fix it, but they referred me back to the software vendors (Mozilla, Adobe).  

Is there a way we could get a simpler reproducible test case?  (I tried finding the row.png image mentioned above on my hard disk but couldn't.)

Is the problem rendering gradient filled PNGs? That seems odd at least from a graphics driver perspective.  (I'd be less surprised if there were problems with alpha-blended (png) image rendering issues.)

Is the Chrome UI rendered using a DirectX graphics pipeline/driver or an OpenGL driver?

Comment 60

12 years ago
OK, Running a TNT2 Model64 I tried the Whitehart Theme for TB and FF.  Still no cure, so I degraded hardware accel one notch, and it displays OK.  Now I thought, I'll try with the original theme, but I can't get it to light up to use or reinstall.  Anybody got any ideas?  Thanks for the feedback.

Comment 61

12 years ago
Now you laugh at me.  Finally got the original theme back by uninstalling the Whitehart (figured it was now on disk and could reinstall as needed).  With one notch degraded hardware accel, the original theme works; conclusion:  To me the hardware acceleration was the cure, not the theme change.  Any feedback?

Comment 62

12 years ago
I also have nVidia Geforce2go on Dell 8100 laptop.

I wanted to see if I could create a row.png that wouldn't cause problems, but I couldn't find it on my hard drive either. Can someone please tell us where it is located?

chrome://messenger/skin/icons/row.png

What does that mean, in terms of path?

Comment 63

12 years ago
Oh, and changing to Whitehart did not work for me, but lowering hardware accel did help.
C:\Program Files\Mozilla Thunderbird\chrome\classic.jar (which is just a ZIP file, despite being named .jar) contains \skin\classic\messenger\icons\row.png

Comment 65

12 years ago
Okay, I made a new row.png that alleviates the problem, but I need to change the css. Can you tell me which file in the classic.jar archive has the style:

#threadTree treechildren::-moz-tree-row(odd) {
  background-image: url("chrome://messenger/skin/icons/row.png");
  background-position: bottom;
  background-repeat: repeat-x;
}

???

Comment 66

12 years ago
This classic.jar is a drop in replacement. Made a new row.png file to avoid overstruck text issue with Dell + nVidia computers. 

goes in
c:\Program Files\Mozilla Thunderbird\chrome\

Comment 67

12 years ago
I found the style rule in the file mailWindow1.css. But it isn't the style we need.

After I made a new row.png, the overstruck text problem disappeared, but now when you select every other message in the message list, the text of the subject and the sender turn white and can't be read against the light color of row.png.

I can make a darker row.png, but it doesn't look right.

So I am wondering how do we find the style rule that controls the color of the text when the odd rows are selected.

Anyhow, you can download a temporary copy of classic.jar with the new row.png here:
http://putstuff.putfile.com/77712/711175

Comment 68

12 years ago
The problem disappeared on my work computer when I changed from graphics adapter vendor's driver to PC vendor's driver, that is:

Driver with the problems in Firefox, Thunderbird and Reader:
"NVidia Vanta", 4.5.2.3, 2003-07-28
The "new" driver without problems:
"NVIDIA Vanta 16 MB (Compaq)", 1.5.7.0, 2001-09-27

I do not know if it was actually downgrading of the driver, however, the latter one is the newest driver officially supported by HP/Compaq.

Comment 69

12 years ago
for TimVan Buren

if your fix works could you please spell out the exact the procedure for adding the the fix as I am challenged with some of this language!

Comment 70

12 years ago
Download classic.jar from the putstuff link, above.

Close Thunderbird.

Put classic.jar in the folder

c:\Program Files\Mozilla Thunderbird\chrome\

I think this is only a temp fix. The color style doesn't quite look right, but at least the overstrike problem is fixed.

Comment 71

12 years ago
while I appreciate Tim making a new classic.jar file..for end users looking for a work around please use the work around I put in comment 44:

https://bugzilla.mozilla.org/show_bug.cgi?id=352694#c44

that's the official work around. I'd like to get that rolled into an XPI that users who run into this can install as an extension.

Replacing classic.jar in your thunderbird installation is not encouraged or recommended. It will also cause issues with software update for future stability releases. Thanks!

Comment 72

12 years ago
I can confirm that this bug manifests itself on a Dell Inspiron 8100 running Windows XP Service Pack 2, with an Nvidia GeForce2Go adapter using a driver made by NVIDIA Corporation where file version of nv4_mini.sys in directory %SYSTEMROOT%\System32\drivers is 6.14.10.4482. (latter four digits is reported as driver version in Device Manager). (I have also encountered problems in Acrobat 8 as mentioned earlier in this thread).

This is the same version of the driver, but different version of the operating system, than reported in comment #57.

I can also confirm that the workaround in comment 44 fixes the problem on this configuration.

Updated

12 years ago
Whiteboard: Workaround: https://bugzilla.mozilla.org/show_bug.cgi?id=352694#c44

Comment 73

12 years ago
anyone want to take a stab at turning my suggested work around into an extension? I'll put it on addons and link to it in the release notes if you do.
Duplicate of this bug: 382689
(In reply to comment #73)
> anyone want to take a stab at turning my suggested work around into an
> extension?

Shouldn't take longer than 5 minutes. Is it still needed?

Comment 76

12 years ago
Dao, that would be great if you could put that together. Thanks!
Attachment #264212 - Attachment is patch: false
Attachment #264212 - Attachment mime type: text/plain → application/java-archive
To John DeRosa(bug opener):

It looks for me that your original problem occurs on mails in a specific thread only. If this is true, phenomenon of your original problem is possibly DUP of or similar problem to Bug 341568. (trunk : fixed on 4/09, 1.8.1 branch : not yet. See Bug 341568 comment #24.)
Phenomenon reported to Bug 341568 is "blank subject", but garbage can be appear before the blank. So similar phenomenon to this bug may occur on Thread Pane display by Bug 341568.

When Bug 341568, cause was found that invalid(no-colon) mail header just before proper Subject: header.
Does problem occur randomly? Or always occur when specific mails?
Is there any special characteristics in the mails?
Is problem re-created by latest-trunk nightly?
Does you original problem look to involve graphics card related issue?

Comment 79

12 years ago
Great work Dao, I've verified that your extension properly implements the 'hot fix'. 

Do you want the honors of putting this up on addons.mozilla.org or would you like me to? Once it's there, post back in the bug and I'll  update the release notes linking to the addon.
The extension fixes the problem also for me. Great work!
https://addons.mozilla.org/thunderbird/addon/5204
It's still in the sandbox currently.
(Reporter)

Comment 82

12 years ago
(In reply to comment #78)
> It looks for me that your original problem occurs on mails in a specific thread
> only.

No, that's not true.  It happened all the time, to every thread.

> Does problem occur randomly? Or always occur when specific mails?

It occurred randomly, in that sometimes the pane was fine, and other times all the subject strings were garbled.

However, when it happened, it happened to every string in the page.

> Is there any special characteristics in the mails?

No.

> Is problem re-created by latest-trunk nightly?

Per comment no. 28, I've been running the Whitehart TB 2.0 theme as a work-around ever since comment no. 28.  So I can't say if my bug is still in the nightlies.

I have now just uninstalled the Whitehart TB theme.  I'll let you know if the problem occurs again, and if it does I'll try loading Dao's extension.

> Does you original problem look to involve graphics card related issue?

If you're asking whether my graphics card is an NVidia card, the answer is yes.
(Reporter)

Comment 83

12 years ago
(In reply to comment #82)
> (In reply to comment #78)
> > Is problem re-created by latest-trunk nightly?
> 
> Per comment no. 28, I've been running the Whitehart TB 2.0 theme as a
> work-around ever since comment no. 28.  So I can't say if my bug is still in
> the nightlies.
> 
> I have now just uninstalled the Whitehart TB theme.  I'll let you know if the
> problem occurs again, and if it does I'll try loading Dao's extension.

And the answer is, yes the bug I saw is still in the latest nightly.

Now, I'll try the extension.
(Reporter)

Comment 84

12 years ago
Update: The extension fixed the problem on my system.
I left a note on AMO, pointing to this bug and asking if the extension could be
unlocked.

Here's the answer:

> Your nominated add-on, Hot Fix for 'garbage in
> folder contents pane' bug, has been reviewed by a
> Mozilla Add-ons editor who decided to retain your
> add-on in the sandbox.
> 
> Review Information:
> Reviewer: Pavel Cvrcek
> Comments: Sorry but your add-on don't have reviews
> from users. Please read these documents:<br />
> https://addons.mozilla.org/en-US/firefox/pages/policy<br
> />
> http://shawnwilsher.com/archives/103<br />
> Please get reviews and then renominate. Thanks for
> your work.

Comment 86

12 years ago
I added a review comment saying I've reviewed the code and the functionality.

Comment 87

12 years ago

Comment 88

12 years ago
Thunderbird 2.0.0.4 under Windows 2000 SP4
brian: try the extension that fixes this
<https://addons.mozilla.org/en-US/thunderbird/addon/5204>

BTW, should we mark this bug FIXED now? I assume there isn't much besides the extension we could do here.

Comment 90

12 years ago
I don't think it should be marked fixed as it currently stands, requiring an extension to be installed after sifting through a long list of bug reports, etc....It should be something that happens automatically, the software should auto-detect the display driver info, and do the right thing if it's an older nVidia driver.  I just spent 2 hours figuring out how/where to install the extension fix for this....

At the very least, there should be a loud warning in the release notes, etc...

The theme display does not look nearly as nice, either (without the altenating line colors)....

By the way the problem does not happen with the 3.0pre* versions I tried.

Also, it's really just a work-around, do we know why this bug is occurring, is it being blamed on the graphics driver and not thunderbird itself?  That sounds a bit unlikely to me....

For the record, I saw the problem as reported, after upgrading to 2.0 from 1.5, and I have Windows 2000 sp4, with a RIVA TNT2 with driver 6.14.10.4523 from nVidia, running on a Micron PC (not a Dell)....
Duplicate of this bug: 389842
release note regarding https://addons.mozilla.org/en-US/thunderbird/addon/5204 - didn't find.
Keywords: relnote
Version: unspecified → 2.0
Duplicate of this bug: 392416
Duplicate of this bug: 392530

Comment 95

12 years ago
I believe the problem stems from the NVIDIA graphics driver rather than a bug in Thunderbird. I had the same problem of an illegible folder contents panel in TBird, as well as the problem with Adobe pdf files, and some occasional minor garbling in Firefox tabs.

I recently updated my NVIDIA drivers to 6.14.10.5673 and the problem is solved. I did not reduce the hardware acceleration (still at full) nor change Thunderbird themes. The folder lists now display perfectly with zebra striping. Similarly, the problem with Adobe pdf files is gone, as is the occasional Firefox tab issue.

I am running Win XP Pro with a NVIDIA RIVA TNT2 Model 64 Pro card on an older Dell machine.

Incidentally, the updated drivers were not easy to find on NVIDIA's site. I was eventually pointed to and downloaded the package at http://www.nvidia.com/object/winxp_2k_71.89.html

I deleted my existing drivers through the Add/Remove applet in Control Panel, then ran the 71.89 install package. Despite the TNT2 card being listed as supported by that package, the installation terminated with a message stating that there was no hardware on my machine that the package supported. Nevertheless, when I checked the drivers for the graphics card in Device Manager, it listed nv4_mini.sys and nv4_disp.dll, both version 6.14.10.5673. I suspect that these drivers came from a Windows folder on my machine, rather than the downloaded NVIDIA package.

Regardless, the drivers are newer than what I was previously using and newer than those listed by any user here. And most important, they cured the problem.
Duplicate of this bug: 392560
Duplicate of this bug: 392574
Duplicate of this bug: 392586
Duplicate of this bug: 392603

Comment 100

12 years ago
I'll get this posted to the release notes today. Sounds like a lot of 1.5 users are running into this.
Duplicate of this bug: 392607

Updated

12 years ago
Duplicate of this bug: 392624

Comment 103

12 years ago
I had the problem of text being garbled or overwritten, too.  Also, moving through the messages via the up and down arrows caused weird highlighting, as though every other message was being selected.

Dao's hotfix cleared up these problems, but at the cost of removing the "zebra striping."  I did not like this.  I decided to turn my graphics card's hardware acceleration down one notch from full.  This seems to have worked.

Note: both workarounds also seem to fix the "tab ghosting" problem in Firefox v2.

System details:
  System: Dell Precision 330, 256 MB RAM
  graphics card: NVIDIA RIVA TNT2/TNT2 Pro -- according to Windows, no driver updates are available for this through Windows Update, although it did offer other drivers to use in lieu of the current one. 
  OS: Windows 2000 SP4 (build 5.00.2195)
  Thunderbird settings: v2.0.0.6, default theme, no userChrome.css file, only addon installed is Talkback.  Basically, as it comes "out of the box."

The problem does *not* present on my laptop: Gateway Solo 9300, 256 MB RAM, same OS and Tbird versions, graphics card: ATI Rage P/M Mobility AGP 2X, hardware acceleration set to full.

If you're interested, I posted a longer version of this report on the Tbird support forums:

  http://forums.mozillazine.org/viewtopic.php?p=3016525#3016525

Hope this helps.
Duplicate of this bug: 392687
Duplicate of this bug: 392719

Comment 106

12 years ago
(In reply to comment #100)
> I'll get this posted to the release notes today. Sounds like a lot of 1.5 users
> are running into this.

It would be very helpful to have this problem listed in the "Known Issues" section of the release notes, along with a link to the extension, and also a note on the other known workarounds (e.g., reducing hardware acceleration or different themes). The MZ forums are getting a lot of visitors with this problem after the 1.5/2.0 upgrade, guess I've answered to 8-10 people over the last 2-3 days.

Comment 107

12 years ago
My experience pretty much mirrors that as documented by "Lawman 13" (2007-08-16, #95).  I have the same NVIDIA board (RIVA TNT2 64), for which NVIDIA site showed no driver.  I downloaded the TNT TNT2 version, got the same "no hardware" message, however the overprinting problem did go away.  Now, I am not sure whether it had to do with a supposed new driver, or whether it was just due to rebooting the Windows 2000 on my rather dated Micron.

Note, I never saw this overwriting problem before while running 1.5, only happened on the 2.0 upgrade for which it appeared that I had no choice but to accept.

Things have been stable for a couple of days now, so... ?

Comment 108

12 years ago
I have the same problem (Nvide Graphic Card) in the default theme. It worked find until the update to 2.0.0.6.
Please find a solution a other theme is ok and I did not change my graphic card driver (no support any more).
Duplicate of this bug: 392828

Comment 110

12 years ago
Possible release notes text:

Users with NVIDIA RIVA TNT2 based graphics cards may see overlapping or garbled text in the message list pane. This is caused by a bug with the current version of your NVIDIA drivers. You can fix this problem by: (1) upgrading your NVIDIA video drivers (2)turning down hardware acceleration one notch by going to Control Panel -> Display -> Settings tab -> Advanced -> Troubleshooting tab
or (3) downloading the <a href="https://addons.mozilla.org/en-US/thunderbird/addon/5204">hot fix Thunderbird extension</a> which works around the problem.

We could also link over to: http://forums.mozillazine.org/viewtopic.php?p=3016525&sid=f0b0731096a62fe35de3595349069194#3016525

Comment 111

12 years ago
I've downloaded the latest driver, from nVidia's web-site, for Windows 2000.  It appears to be rev 6.14.10.4523 (you actually download a jumbo install package, which I guess decided which driver to install for the particular platform)....It does not solve the problem.

I've seen a posting where someone installed a driver version 6.14.10.5673, but that appeared to be for an XP system, and it fixed the problem there.  But for Windows 2000, I can atest that the latest driver on the nVidia web-site does not solve the issue.

Jason

Updated

12 years ago
Duplicate of this bug: 392854

Comment 113

12 years ago
(In reply to comment #110)
> Possible release notes text:
> 
> Users with NVIDIA RIVA TNT2 based graphics cards may see overlapping or garbled
> text in the message list pane. [...]

Please add GeForce2 (or GeForce2 Go) to this list, as of comment #72 and several others before that.
Duplicate of this bug: 393032

Updated

12 years ago
Duplicate of this bug: 393208
Duplicate of this bug: 394287

Comment 117

12 years ago
This has been going on for quite a while now.  Where is the fix for it?  I've switched back to Microsoft Outlook now... think I'll wait for a revision of Thunderbird's program.  In the meantime, Outlook is fine.

Comment 118

12 years ago
The fix is to update your nvidia device driver - see https://bugzilla.mozilla.org/show_bug.cgi?id=352694#c110

Comment 119

12 years ago
hot fix works! 
Description for installation is wrong.
Hint: download "hot_fix_for__garbage_in_folder_contents_pane__bug-1.0-tb-win.xpi" to disk - drag&drop downloaded file to the "Extras"-"Add-on"-window you had opened from Thunderbird. Then press install.

good luck

Comment 120

12 years ago
A "fix" is a nice thing, but how about a better version of Thunderbird that, will install itself over the flawed version?  That would be a clean remedy.

Comment 121

12 years ago
A "fix" is a nice thing, but how about a better version of Thunderbird that, will install itself over the flawed version?  That would be a clean remedy.

Comment 122

12 years ago
I agree with G. Larson (comment 120).  The download for the Nvidia update is something like 74 MB, and there is no documentation about it.  Many of us with aging computers are hesitant to blast something of this nature onto our machines, since it's not at all clear how to unroll it, should other problems result.

Comment 123

12 years ago
Well, I don't have the time to spend troubleshooting anymore. I'll move on and find a different email program. There are others to choose from and apparently there was a change that went into effect that got more than just me hung up and the "fix" is to install a different theme? That really scares me about the quality of the rest of the code.

Comment 124

12 years ago
The newer version of Thunderbird is using a graphics feature to make it easier to distinguish between items in the message list.  For people with non-buggy video card drivers, it's an improvement, not a "flaw". Note that Acrobat 8 has a similar issue, despite not sharing a single line of code with Thunderbird.

Comment 125

12 years ago
I really agree with Gary (comment #123).  I'll stay with Microsoft Outlook, so as not to risk any more email problems.  When the quality of code improves and all these major issues are resolved, I may come back.  Right now, my time is worth a lot to me, and trying out various "fixes" that pose more risks seems silly for me to continue working with.  I had not realized I was replacing something that worked with a beta version. I'll keep checking back, from time to time, just in case new code for the Thunderbird program is created.  

Comment 126

12 years ago
Hi,

I had two computers where I had this problem.

1. Windows XP

Updating to the latest NVIDIA driver solved the issue

2. Windows 2000

Updating to the latest (71.89) driver did <b>NOT</b> solve the issue.

Reducing the acceleration one position has (so far) worked for the Windows 2000 machine.

It would be useful to separate out the available fixes by platform in the release notes.

Thanks,
Anand 

Comment 127

12 years ago
The hot fix located at the following link worked.   
"https://addons.mozilla.org/en-US/thunderbird/addon/5204"

I have the same NVIDIA card as mentioned in the above comments.  Unfortunately, the hot fix works by "overriding the critical bits in the new theme".  It would be nice if there was a fix that really did fix the problem.  Well, at least I can now see the words in the panel.  Anyway, my computer is old and it's about time to buy a new one.



Comment 128

12 years ago
Upgrading the NVIDIA driver was the fix I needed. My only complaint is that I had to read down several dozen comments to find it, passing 3 other workarounds along the way. If it could be placed in the bug description, it would save people a lot of trouble. 

Comment 129

12 years ago
Thanks for the feedback Eric! I'd like to mention that this problem and the solutions are listed under the Known Issues section of the Thunderbird 2 release notes:

http://en-us.www.mozilla.com/en-US/thunderbird/2.0.0.6/releasenotes/

"Users with NVIDIA RIVA TNT2 or GeForce2 based graphics cards may see overlapping or garbled text in the message list pane. This is caused by a bug in the NVIDIA drivers. You can fix this by: upgrading your NVIDIA video driver OR turning down hardware acceleration one level by going to Control Panel -> Display -> Settings -> Advanced -> Troubleshooting OR downloading this extension for Thunderbird which works around the problem."

Hopefully most end users will look in the release notes before going into bugzilla, finding this bug, and reading through all of our discussions here.

Comment 130

12 years ago
I think it would be helpful to add to the release note, that the option of upgrading to the latest nVidia driver works for XP systems, but not Windows 2000.

Jason
Duplicate of this bug: 392723
Duplicate of this bug: 393164
Duplicate of this bug: 397442
I think I may have found a trigger and a common ground for this issue

Nvidia Riva TNT2 M64 graphics card/drivers

Trigger, increasing or decreasing the font sizes using the Ctrl + "+" & Ctrl + "-" in Firefox works perfectly, but after doing so, Thunderbird produced the garbled messages and the increase/decrease font size keyboard shortcut would not work in Thunderbird.

Updated

11 years ago
Duplicate of this bug: 417978
Duplicate of this bug: 428731
Does anyone know if this bug occurs on Thunderbird nightlies off of trunk (3.0pre)?

Comment 138

11 years ago
I have an older Dell Inspiron 8000 with the Nvidia GeForce2go video board apparently. This is the second time the 'overwriting' has happened after upgrading Thunderbird. It is as previously described, on the darker lines of the subject and  sender lines. I have a jpg available at the link below. I can't remember how I got rid of it the last time, perhaps changing how it displays or maybe removing Thunderbird entirely and reinstalling. Haven't had the issue come back until today when I upgraded.
http://www.silverdalemedia.com/thunderbird/tbird_issue.jpg
Brian Nokell (or anyone else) -- have you tried Thunderbird 3.0a1 or a2 nightly builds?  It'd be good to know if the issue still occurs with the recent mozilla platform.
based on last comment, this is fixed on trunk, so won't block tb3.  I doubt this will get fixed on branch either, fwiw.
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Assignee: mscott → nobody
Duplicate of this bug: 454065
Duplicate of this bug: 462486
Duplicate of this bug: 471464

Updated

10 years ago
Duplicate of this bug: 499291
Duplicate of this bug: 515968
Based on comment #90 this is fixed on latest TB 3.x: wontfix - as it workd in 3.0 and 2.x is a stability and security release branch.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.