Java applets don't work until an administrator loads one

RESOLVED WORKSFORME

Status

()

Firefox
Installer
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Harry Johnston, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Java applets don't work for non-administrators, unless an administrative user has already loaded one.  This appears to be because the Firefox installer isn't creating the necessary registry value CurrentValue in HKLM\SOFTWARE\mozilla.org\Mozilla.

I believe the installer is creating the value in HKLM\SOFTWARE\Mozilla\Mozilla instead.

When an administrative user loads a web page containing a Java applet the necessary registry value is created automatically, but this isn't possible when the user isn't an administrator.  Sysinternal's regmon tool indicates that an attempt to create the relevant key was refused with an access denied error.


Reproducible: Always

Steps to Reproduce:
1. Start with a clean OS, or manually delete the registry key HKLM\SOFTWARE\mozilla.org.
2. Install Firefox 1.5.0.7 and the 1.5.0_06 (or later) Sun Java runtime.  Do not visit any web pages containing Java applets.
3. Log out and back on as a user without administrator privilege and go to any web page containing a Java applet (such as the NASA page listed above).

Actual Results:  
The Java applet does not start.  The Java notification icon does not appear.

Expected Results:  
The Java applet should run.

I checked Firefox 1.5.0.6 and 1.5.0.4 and they both had the same problem.
I would expect the app to create that key in HKCU in that instance and Java to look there as a fallback
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> I would expect the app to create that key in HKCU in that instance and Java to
> look there as a fallback

I can confirm that neither of these happens.  Firefox does not create the key in HKCU, and manually creating the key in HKCU does not make Java work.
I'm trying to think of why Java would check that key... doesn't make any sense to me and I haven't seen any docs stating plugins should check that key. Anyone know?
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/09
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 5

11 years ago
Yes, this problem still exists in the latest versions - Firefox 2.0.0.4 with Sun Java 6 update 1.
Whiteboard: CLOSEME 07/09

Updated

11 years ago
Version: 1.5.0.x Branch → 2.0 Branch
(Reporter)

Comment 6

10 years ago
Firefox no longer exhibits this problem.  Looks like it was fixed in one of the recent versions (somewhere between 2.0.0.8 and 2.0.0.10 inclusive).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.