Download Manager can not be opened from the Tool Menu

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: tgrabow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5

Selecting the Download Manager from the Tool Menu no longer opens the Download window.   
This resulted from upgrade to 1.0.5

Reproducible: Always

Steps to Reproduce:
1.Go to Tools Menu
2.select Download Manager
3.

Actual Results:  
Nothing happens

Expected Results:  
The download manager window opens 

Problem introduced in 1.0.5
How did you upgrade to the new version? Have you used the installer or just copied the content of the zip file over the installed version?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> How did you upgrade to the new version? Have you used the installer or just
> copied the content of the zip file over the installed version?
> 

Upgrade via installer
I can't reproduce this, works fine for me. Can you have a look in the Javascript Console (under Tools - Web Development) after the error occured? Are there any errors or warnings shown (if there's already a lot of content in the console, clear it and try it again)?

(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
Error: uncaught exception:
[Exception... "Component returned failure code:
0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"
nsresult:
"0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"
location: "JS frame :: chrome://communicator/content/tasksOverlay.js
 :: toDownloadManager ::
 line 51"  data: no]
 

This can be the effect of a corrupt compreg.dat. You can try to fix this by deleting compreg.dat in your profile. It will be regenerated with the next browser start.
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> This can be the effect of a corrupt compreg.dat. 

You were correct.  Removed compreg.dat. File regenerated and works fine.

PROBLEM SOLVED

Thank you
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.