crash while printing [@ libfontconfig.so.1 + 0xba77] [@ nsFontMetricsPS::~nsFontMetricsPS]

RESOLVED DUPLICATE of bug 294879

Status

--
critical
RESOLVED DUPLICATE of bug 294879
12 years ago
7 years ago

People

(Reporter: bob.lord, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
TB is crashing after I print an email.

Talkback incicidents:
TB23325760Z
TB23325716G

Comment 1

12 years ago
Incident ID: 23325716
Stack Signature	libfontconfig.so.1 + 0xba77 (0x00fcea77) 016d9803
Product ID	Thunderbird2
Build ID	2006091503
Trigger Time	2006-09-15 10:28:27.0
Platform	LinuxIntel
Operating System	Linux 2.6.17-1.2630.fc6xen
Module	libfontconfig.so.1 + (0000ba77)
URL visited	
User Comments	Trying to print
Since Last Crash	0 sec
Total Uptime	0 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libfontconfig.so.1 + 0xba77 (0x00fcea77)
nsFontMetricsPS::~nsFontMetricsPS()  [mozilla/gfx/src/ps/nsFontMetricsPS.cpp, line 111]
nsFontMetricsPS::Release()  [mozilla/gfx/src/ps/nsFontMetricsPS.cpp, line 135]
nsFontCache::Flush()  [mozilla/gfx/src/nsDeviceContext.cpp, line 709]
nsFontCache::~nsFontCache()  [mozilla/gfx/src/nsDeviceContext.cpp, line 580]
nsFontCachePS::~nsFontCachePS()
DeviceContextImpl::~DeviceContextImpl()  [mozilla/gfx/src/nsDeviceContext.cpp, line 89]
nsDeviceContextPS::~nsDeviceContextPS()  [mozilla/gfx/src/ps/nsDeviceContextPS.cpp, line 134]
DeviceContextImpl::Release()  [mozilla/gfx/src/nsDeviceContext.cpp, line 54]
nsCOMPtr_base::~nsCOMPtr_base()  [mozilla/xpcom/build/nsCOMPtr.cpp, line 81]
nsPrintData::~nsPrintData()  [mozilla/layout/printing/nsPrintData.cpp, line 159]
nsPrintEngine::Destroy()  [mozilla/layout/printing/nsPrintEngine.cpp, line 284]
DocumentViewerImpl::OnDonePrinting()  [mozilla/layout/base/nsDocumentViewer.cpp, line 4244]
HandlePLEvent()  [mozilla/layout/printing/nsPrintEngine.cpp, line 4554]
PL_HandleEvent()  [mozilla/xpcom/threads/plevent.c, line 688]
PL_ProcessPendingEvents()  [mozilla/xpcom/threads/plevent.c, line 623]
nsEventQueueImpl::ProcessPendingEvents()  [mozilla/xpcom/threads/nsEventQueue.cpp, line 421]
event_processor_callback()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 71]
libglib-2.0.so.0 + 0x5494d (0x03afa94d)
libglib-2.0.so.0 + 0x2b342 (0x03ad1342)
libglib-2.0.so.0 + 0x2e31f (0x03ad431f)
libglib-2.0.so.0 + 0x2e6c9 (0x03ad46c9)
libgtk-x11-2.0.so.0 + 0x12bc04 (0x06905c04)
nsAppShell::Run()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
XRE_main()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 848]
main()  [mozilla/mail/app/nsMailApp.cpp, line 63]
libc.so.6 + 0x15f2c (0x006ecf2c)
Assignee: mscott → nobody
Severity: normal → critical
Component: General → GFX: Gtk
Keywords: crash
Product: Thunderbird → Core
QA Contact: general → gtk
Summary: crash while printing → crash while printing [@ libfontconfig.so.1 + 0xba77] [@ nsFontMetricsPS::~nsFontMetricsPS]
Version: unspecified → 1.8 Branch

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 294879 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard
(Assignee)

Updated

7 years ago
Crash Signature: [@ libfontconfig.so.1 + 0xba77] [@ nsFontMetricsPS::~nsFontMetricsPS]
You need to log in before you can comment on or make changes to this bug.