Cannot add subgroup into Litmus TestGroups

RESOLVED FIXED

Status

Webtools Graveyard
Litmus
--
major
RESOLVED FIXED
11 years ago
a year ago

People

(Reporter: cmtalbert, Assigned: coop)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Adding a subgroup into Litmus states that it works, but the subgroup is not available for adding to a testgroup.

I have left the Build Identifier as the firefox ID, since that's the version of firefox I'm using, in case that matters.

Reproducible: Always

Steps to Reproduce:
1. Go to manage subgroups
2. Add a subgroup to Project Calendar Testgroup: Sunbird FFT
3. Type in a subgroup name and click add
4. Go to Manage TestGroups, select Project Calendar
5. Check the list of "all subgroups" on the left side.

Actual Results:  
Subgroup is not available. 
It doesn't show up at all.

Expected Results:  
The subgroup would be available to add to the testgroup. Or, in a perfect world, the add after step 3 would have added it to the selected Test Group.


This used to work as recently as August 18th, 2006. I don't know what happened to this. Zach and I discussed this in #calendar, and he tried rebuilding the Litmus cache but the bug persisted. He directed me to file this one.

I'm going to make this a "Major" feature, because this is clearly a regression in functionality, and it is hampering some of our test case development work in Calendar.

We will use the workaround of adding "ungrouped" testcases to a certain existing subgroup for now.
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

11 years ago
This should be fixed now.

Go into 'Manage Testgroups,' select the testgroup you wish to manage (Sunbird FFT), and then select the '-Branch' option in the "Branch(es)" dropdown. This will allow you see subgroups that belong to the same product (Calendar) but have not yet been assigned to a testgroup, and hence have no associated branch information. Not necessarily intuitive, but it should get the job done.

Clint: can I also ask you to remove some of the testing/bogus subgroups that I noticed in the db from when you were probably trying to get this working before? Thanks.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> This should be fixed now.
> 
> Clint: can I also ask you to remove some of the testing/bogus subgroups that I
> noticed in the db from when you were probably trying to get this working
> before? Thanks.
> 
Yes, I'll do that.

Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.