Memory leak at code.google.com

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Steve Chapel, Unassigned)

Tracking

({mlk})

Trunk
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Reproducible: Always

Steps to Reproduce:
1. Go to http://code.google.com/p/airbag/

After opening the URL with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060911 Minefield/3.0a1, the leak gauge reports:

Leaked outer window 22b70d0 at address 22b70d0.
Leaked inner window 192c7d8 (outer 22b70d0) at address 192c7d8.
 ... with URI "http://code.google.com/p/airbag/".
Leaked inner window 2a182d8 (outer 22b70d0) at address 2a182d8.
 ... with URI "http://www.mozilla.org/projects/minefield/".
Leaked document at address 1f71410.
 ... with URI "http://www.mozilla.org/projects/minefield/".
Leaked document at address 2e5b7a0.
 ... with URI "http://code.google.com/p/airbag/".
Summary:
Leaked 3 out of 8 DOM Windows
Leaked 2 out of 39 documents
Leaked 0 out of 3 docshells

After opening the URL with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060913 SeaMonkey/1.1b, the leak gauge reports:

Leaked outer window 14c4790 at address 14c4790.
Leaked outer window 1d3c6f0 at address 1d3c6f0.
Leaked inner window 1f83ef0 (outer 1d3c6f0) at address 1f83ef0.
 ... with URI "http://code.google.com/p/airbag/".
Leaked inner window 14cc3a0 (outer 14c4790) at address 14cc3a0.
 ... with URI "about:blank".
Leaked document at address 1a0c018.
 ... with URI "http://code.google.com/p/airbag/".
Summary:
Leaked 4 out of 15 DOM Windows
Leaked 1 out of 34 documents
Leaked 0 out of 6 docshells

Comment 1

11 years ago
Relies on http://code.google.com/js/dit_scripts_20061204.js, 

data:text/html,<script src="http://code.google.com/js/dit_scripts_20061204.js"></script>

also leaks.

Comment 2

11 years ago
Nevermind. I swear that data url leaked once, but now it doesn't. Maybe the browser wasn't finished closing or something.
(Reporter)

Updated

10 years ago
(Reporter)

Comment 3

10 years ago
leak-guage.pl shows no memory leaks with either the original URL http://code.google.com/p/airbag/ or the new URL http://code.google.com/p/google-breakpad/ with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007100605 Minefield/3.0a9pre. WFM?
I can't reproduce either.  Too bad we don't know whether whatever made the problem go away was on our side or theirs...
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite-
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.