bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Option to change default E-mail client: where?




12 years ago
12 years ago


(Reporter: Gunther Steinberg, Unassigned)


1.5.0.x Branch
Windows 2000

Firefox Tracking Flags

(Not tracked)




12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv: Gecko/20060909 Firefox/
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv: Gecko/20060909 Firefox/

MY normal default E-mail client is Eudora.
File-> Sen Link  leads mne to G-mail client.
Tools-> new message leads me to G-mail client
GO: has an entry in the menu G-Mail

I have been unable to find a method for changing the DEFAULT E-mail client.
No entry in HELP.
No entry in reported bugs that I can match.

Reproducible: Always

Steps to Reproduce:
1. Go to all the menus and check them -> all lead to G-mail.

Actual Results:  
Everything leads me a G-mail screen instead of Eudora.

GO menu or File-Send Link or Tools-Options should have a means for entering the default E-mail client and location.
The default mail client comes from querying the OS (in XP: Start > Set Program Access and Defaults). You must have an extension that catches mail related tasks first, because Firefox doesn't do that by default.

This isn't a valid bug in Firefox.
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 2

12 years ago
I dop not agree with your "resolution".
Windows 2000 - Control Panel - Mail never had G-mail entered as an account.
(in fact it had an obsolete E-amil account in it).

Something tells Firefox to go to G-mail via the File - Send Link or
Tools - New Message links.
NOTE that when I click on MAIL- READ, it goes to Eudora.
MAIL- New Message brings up G-mail.

Something tells Firefox what E-mail client to start. It is not the default client, Eudora or the OS.
If there were a means of setting it within Firefox, the matter would be mute.
Resolution: INVALID → ---

Comment 3

12 years ago
Please answer the questions. Do you an extension that does that... (I know there is one.) Is the problem still there if you start firefox in -safe-mode?

Comment 4

12 years ago
Answers:  I have extension that controls E-mail, nor could I find one after searching quite thoroughly.
Firefox menus don't work when it is opened in the safe mode (with Win2000)

Looking at Win2K HELP: the only setting for E-mail are for OutlookExpress. There Eudore is the default.

Firefox HELP: Send Link...
    Opens an email composition window using your computer's default email program
    so you can send a message with a link to the current page.

Something is not right since G-mail has never been my default E-mail client.
-W2K Search for " Default E-mail Program ->  ZERO

Icon in START (after installation of SP4)
<Set Program Access and Defaults>: this is a typical MS lousy help system.
 For E-mail it does not show any program except a choice of [ ] Outlook Express or [ ]Mozilla Mail and [X} Use Current E-mail program. The latter is not shown by name; neither Eudora nor G-mail.

So one cannot really tell what it is for sure, except if it is a Microsoft one.

Therefore, it would be nice if Firefox were to make it possible to set the Default.

From a long time ABM user; ABM = anything but Microsoft
Comment #3 really meant Firefox's safe mode rather than windows. 

I have no idea how Firefox came to use Gmail for mail related tasks - it does not do this my default - but the extension WebmailCompose and Google's GMail notifier are likely suspects. I don't believe there is a bug in Firefox - it doesn't make sense to configure a default mail client in every application that has some email tasks, you do it once for the whole the OS. 

Bugzilla is also not the place to get support. Please use the proper support channels to get help from other users, info at:
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
Version: unspecified → 1.5.0.x Branch

Comment 6

12 years ago
YES, you are correct. The way to set it is not in the Win2000 OS, but in Eudora -
Options - Extra Warnings - [v]Start Eudora and it it is not the default mailer.

When that is checked, ,Send Link  will bring up Eudora.
The slightly obscure language and lack of HELP directions are to blame for my confusion. (I have used Eudora for many years; onPCs for 23 years)
You need to log in before you can comment on or make changes to this bug.