Closed Bug 352986 Opened 14 years ago Closed 14 years ago

eval("return") in toString halts javascript execution (even in try..catch)

Categories

(Core :: JavaScript Engine, defect)

PowerPC
macOS
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 352742

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: testcase)

js> j = ({toString: function() { eval("return"); }})
js> print(2); try { "" + j; } catch(e){} print(3);
2

Same happens with "break" and "continue".
This is a dup of bug 352455.

/be

*** This bug has been marked as a duplicate of 352455 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
No, not bug 352455.  But another bug we were discussing recently -- sayrer knows.

/be
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: DUPME

*** This bug has been marked as a duplicate of 352742 ***
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPME
Verifying as a dup.  This works correctly now that bug 352742 is fixed.
Status: RESOLVED → VERIFIED
No longer blocks: 349611
Blocks: 349611
You need to log in before you can comment on or make changes to this bug.