double click selection doesn't work under heavy load

VERIFIED WONTFIX

Status

()

Core
Editor
P4
minor
VERIFIED WONTFIX
18 years ago
17 years ago

People

(Reporter: Marko Macek, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
double clicking in the location bar text field doesn't select the url if the
machine is under heavy load (accessing a parallel port ZIP drive, for example).

Comment 1

18 years ago
Unable to reproduce during 15 seconds of 98%+ CPU load on WinNT on a K6/300, 
using 2000-04-09-08-M15: double-click selection worked reliably in the URL bar.

Marko.Macek@gmx.net, could you please describe your machine and state the 
Build ID of the version of Mozilla you were using? Thanks.
Summary: double click doesn't work under heavy load → double click selection doesn't work under heavy load

Comment 2

18 years ago
Must have missed the radio button... really moving to "Selection" component
this time...sorry.

Comment 3

18 years ago
I can't repro this on win2k (under a simulated 100% load). Marking WORKSFORME
but if there is some other tweak to reproduce this, then please REOPEN with 
details. Thanks. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

18 years ago
also can't reproduce on win2k with heavy load, verifying worksforme until 
further notice.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
Build 2000040908 (I don't believe this is a build specific bug)

It only happens when copying from/to parallel port ZIP drive which causes high 
kernel CPU load (and slows the computer down 95%). It only happens with a slow
(non-EPP) parallel port on NT.

I have also reproduced (not so reliably) by running 5 200% CPU busy loops
(P2 400).

I ran 5 copies of this:

perl -e "while(1) {}"

If you have a faster machine, just run more of them.

I think this should be reopened (it definatelly doesn't work for me :( )

Comment 6

18 years ago
At reporter's request, I'm reopening for the time being to see if anyone is able 
to reproduce this.

lowering severity, this seems like a pretty specific bug that won't come up too 
often.
Severity: normal → minor
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

18 years ago
changing component to editor, reassigning.
Assignee: trudelle → beppe
Component: XP Toolkit/Widgets → Editor
QA Contact: jrgm → sujay
(Assignee)

Comment 8

18 years ago
marking as wontfix, unless this can be reproduced in a braoder range of actions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Priority: P3 → P4
Resolution: --- → WONTFIX
Target Milestone: --- → M16

Comment 9

18 years ago
verified in 4/12 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.