URI tagging fails to include ")" (right bracket) in outgoing text/html messages

RESOLVED DUPLICATE of bug 133016

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 133016
12 years ago
12 years ago

People

(Reporter: Anthony, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Thunderbird 1.5.0.7 (20060909)

This has been tested and confirmed with Thunderbird 1.5.0.5 (Win) and Thunderbird 1.5.0.7 (Win).

When sending a text/html message any URIs that include a ")" character (right bracket) will be broken starting at that character.

An example original URI:
http://somesite.com/somepage?q=Hello+Martin+(Marty)+McFly

After sending via Thunderbird, this URI gets split in two:
Broken URI: http://somesite.com/somepage?q=Hello+Martin+(Marty
Remaining text: )+McFly

Viewing the source of the received message you see the following has occured:
<a class="moz-txt-link-freetext" href="http://somesite.com/somepage?q=Hello+Martin+(Marty">http://somesite.com/somepage?q=Hello+Martin+(Marty</a>)+McFly

According to RFC 2396 2.3 Unreserved Characters, ")" is an unreserved character and so shouldn't need any special escaping to be part of a URI.

A workaround in Thunderbird when sending text/html is to escape ")" with %29 when composing the message. This alleviates the problem but is most definitely a kludge.

The URI does not get broken when sending it in Thunderbird with a text/plain message, nor does it get broken when sending text/plain or text/html from MS Outlook Express 6.00.2800.1807.

Reproducible: Always

Steps to Reproduce:
1. Compose a new text/html message to yourself in Thunderbird.
2. Put a URI including a ")" character in the body of the message, eg: http://somesite.com/somepage?q=Hello+Martin+(Marty)+McFly
3. Send the message.
4. Upon receipt of the message, observe that the URI is broken at the ")" character.

Actual Results:  
After sending via Thunderbird in a text/html message, the URI will be split in two:

Broken URI:
    http://somesite.com/somepage?q=Hello+Martin+(Marty

Remaining text:
    )+McFly

Message source code:
    <a class="moz-txt-link-freetext" href="http://somesite.com/somepage?q=Hello+Martin+(Marty">http://somesite.com/somepage?q=Hello+Martin+(Marty</a>)+McFly


Expected Results:  
The URI should be unbroken, ie:
http://somesite.com/somepage?q=Hello+Martin+(Marty)+McFly

In message source, this should be:
<a class="moz-txt-link-freetext" href="http://somesite.com/somepage?q=Hello+Martin+(Marty)+McFly">http://somesite.com/somepage?q=Hello+Martin+(Marty)+McFly</a>


For a real-world example of a URI commonly including ")" characters, follow these instructions:
1. Go to Google Maps, http://maps.google.com/
2. Enter in the following query: -27° 47' 52.00", +151° 51' 19.00" (Mount Kent Observatory)
3. Press enter, allow the page to finish loading, then right-click Copy Link Location on the "Link to this page" link at the top-right of the page.
4. Paste this URI in to a Thunderbird Compose Message window, sending a text/html message to yourself.
5. Upon receipt of the message notice that the last third of the URI (including the ")" character) is rendered as plain text and is not included in the clickable link which forms the first portion of the URI.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 133016 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.