Crash after opening page [@ libflashplayer.so]

VERIFIED INVALID

Status

()

defect
--
critical
VERIFIED INVALID
13 years ago
8 years ago

People

(Reporter: luke.hutch, Unassigned)

Tracking

({crash})

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

I saved the attached page under an older version of Firefox.  Opening it under 2.0b2 causes it to display with jumbled content, and then waiting a certain number of seconds or mousing over the jumbled content causes Firefox to crash hard.  I just sent in a Talkback report about this.

Reproducible: Always

Steps to Reproduce:
1.Extract the attached page.
2.Open it by double-clicking on the .html file
3.Mouse over the jumbled content
Posted image The jumbled content
A backtrace at the crash point is below.  It turns out that you have to mouse-over the page as it is laying out at the beginning.  A grey rectangle blinks onto the page at different positions several times for a split second (it might be a Java applet?) -- that could be causing the problem.  I have jdk-1.5.0_06.

(gdb) cont
Continuing.
/home/lib/i386/libjavaplugin_nscp.so: cannot open shared object file: No such file or directory[New Thread 110152592 (LWP 18813)]
[New Thread -1247810672 (LWP 18814)]
[New Thread -1269355632 (LWP 18815)]
[New Thread -1280095344 (LWP 18816)]
[Thread -1258300528 (LWP 18782) exited]
[Thread 110152592 (LWP 18813) exited]
[Thread -1247810672 (LWP 18814) exited]
[Thread -1280095344 (LWP 18816) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209120016 (LWP 18768)]
0x04c1faa7 in ?? ()
(gdb) thread apply all bt

Thread 14 (Thread -1269355632 (LWP 18815)):
#0  0xb7f0b402 in ?? ()
#1  0x00b4d17c in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x00d7a176 in PR_Unlock () from Desktop/firefox/libnspr4.so
#3  0x00d7a302 in PR_WaitCondVar () from Desktop/firefox/libnspr4.so
#4  0x08142324 in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
#5  0x081424dc in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
#6  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#7  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#8  0x0094ac1e in clone () from /lib/libc.so.6

Thread 11 (Thread -1211221104 (LWP 18769)):
#0  0xb7f0b402 in ?? ()
#1  0x009410b3 in poll () from /lib/libc.so.6
#2  0x00d7d417 in PR_OpenDir () from Desktop/firefox/libnspr4.so
#3  0x08139a9e in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
#4  0x08139f86 in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
---Type <return> to continue, or q <return> to quit---
#5  0x00c0e97f in nsThread::Main () from Desktop/firefox/libxpcom_core.so
#6  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#7  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#8  0x0094ac1e in clone () from /lib/libc.so.6

Thread 10 (Thread -1221710960 (LWP 18770)):
#0  0xb7f0b402 in ?? ()
#1  0x00b4d17c in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x00d7a176 in PR_Unlock () from Desktop/firefox/libnspr4.so
#3  0x00d7a302 in PR_WaitCondVar () from Desktop/firefox/libnspr4.so
#4  0x00c10a16 in TimerThread::UpdateFilter ()
   from Desktop/firefox/libxpcom_core.so
#5  0x00c0e97f in nsThread::Main () from Desktop/firefox/libxpcom_core.so
#6  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#7  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#8  0x0094ac1e in clone () from /lib/libc.so.6

Thread 9 (Thread 26536848 (LWP 18771)):
#0  0xb7f0b402 in ?? ()
#1  0x00b4d17c in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x00d7a176 in PR_Unlock () from Desktop/firefox/libnspr4.so
---Type <return> to continue, or q <return> to quit---
#3  0x00d7a302 in PR_WaitCondVar () from Desktop/firefox/libnspr4.so
#4  0x081241fd in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
#5  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#6  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#7  0x0094ac1e in clone () from /lib/libc.so.6

Thread 8 (Thread 37026704 (LWP 18772)):
#0  0xb7f0b402 in ?? ()
#1  0x00b4d17c in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x00d7a176 in PR_Unlock () from Desktop/firefox/libnspr4.so
#3  0x00d7a302 in PR_WaitCondVar () from Desktop/firefox/libnspr4.so
#4  0x081241fd in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
#5  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#6  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#7  0x0094ac1e in clone () from /lib/libc.so.6

Thread 7 (Thread 47516560 (LWP 18773)):
#0  0xb7f0b402 in ?? ()
#1  0x00b4d17c in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
---Type <return> to continue, or q <return> to quit---
#2  0x00d7a176 in PR_Unlock () from Desktop/firefox/libnspr4.so
#3  0x00d7a302 in PR_WaitCondVar () from Desktop/firefox/libnspr4.so
#4  0x081241fd in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
#5  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#6  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#7  0x0094ac1e in clone () from /lib/libc.so.6

Thread 6 (Thread 58006416 (LWP 18774)):
#0  0xb7f0b402 in ?? ()
#1  0x00b4d17c in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x00d7a176 in PR_Unlock () from Desktop/firefox/libnspr4.so
#3  0x00d7a302 in PR_WaitCondVar () from Desktop/firefox/libnspr4.so
#4  0x081241fd in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
#5  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#6  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#7  0x0094ac1e in clone () from /lib/libc.so.6

Thread 5 (Thread 68496272 (LWP 18775)):
#0  0xb7f0b402 in ?? ()
#1  0x00b4d17c in pthread_cond_timedwait@@GLIBC_2.3.2 ()
---Type <return> to continue, or q <return> to quit---
   from /lib/libpthread.so.0
#2  0x00d7a176 in PR_Unlock () from Desktop/firefox/libnspr4.so
#3  0x00d7a302 in PR_WaitCondVar () from Desktop/firefox/libnspr4.so
#4  0x086f85c8 in nsXPTCVariant::Init ()
#5  0x086f78e7 in nsXPTCVariant::Init ()
#6  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#7  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#8  0x0094ac1e in clone () from /lib/libc.so.6

Thread 4 (Thread 78986128 (LWP 18776)):
#0  0xb7f0b402 in ?? ()
#1  0x00b4d17c in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x00d7a176 in PR_Unlock () from Desktop/firefox/libnspr4.so
#3  0x00d7a302 in PR_WaitCondVar () from Desktop/firefox/libnspr4.so
#4  0x086e64a6 in nsXPTCVariant::Init ()
#5  0x086f78e7 in nsXPTCVariant::Init ()
#6  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#7  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#8  0x0094ac1e in clone () from /lib/libc.so.6

Thread 3 (Thread -1237320816 (LWP 18779)):
#0  0xb7f0b402 in ?? ()
---Type <return> to continue, or q <return> to quit---
#1  0x00b4cf06 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00d7a363 in PR_WaitCondVar () from Desktop/firefox/libnspr4.so
#3  0x08110ce3 in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
#4  0x08110fd3 in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable$base ()
#5  0x00c0e97f in nsThread::Main () from Desktop/firefox/libxpcom_core.so
#6  0x00d7e578 in PR_Select () from Desktop/firefox/libnspr4.so
#7  0x00b491b9 in start_thread () from /lib/libpthread.so.0
#8  0x0094ac1e in clone () from /lib/libc.so.6

Thread 1 (Thread -1209120016 (LWP 18768)):
#0  0x04c1faa7 in ?? ()
#1  0xbfeac5a4 in ?? ()
#2  0x00000000 in ?? ()
(gdb)
Version: unspecified → 2.0 Branch
Can you please give us the talkback id which was created by sending the report? How to do this is described here: http://kb.mozillazine.org/Talkback
Yeah, that stack does look a little odd. A talkback ID might be more useful.
Keywords: crash
TB23374641G
Oh, that's a dupe of bug 200511.

*** This bug has been marked as a duplicate of 200511 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Summary: Crash after opening page (attached) → Crash after opening page [@ libflashplayer.so]
For what it's worth, I'm not sure I'm OK with duping all "Flash is crashing bugs" to one bug, but whatever.
i don't have any reason to believe this is bug 200511
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
luke: can you retry with the latest flash player?
From comment 6:

Stack Signature	 libflashplayer.so + 0xcbaa7 (0x04c90aa7) 3f62a385
Product ID	Firefox2
Build ID	2006082101
Trigger Time	2006-09-16 16:51:03.0
Platform	LinuxIntel
Operating System	Linux 2.6.17-1.2583.fc6
Module	libflashplayer.so + (000cbaa7)
URL visited	
User Comments	
Since Last Crash	0 sec
Total Uptime	83 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libflashplayer.so + 0xcbaa7 (0x04c90aa7)
libflashplayer.so + 0xce605 (0x04c93605)
libflashplayer.so + 0xd14a1 (0x04c964a1)
libflashplayer.so + 0xd154b (0x04c9654b)
libflashplayer.so + 0xd154b (0x04c9654b)
libflashplayer.so + 0xd154b (0x04c9654b)
libflashplayer.so + 0xd154b (0x04c9654b)
libflashplayer.so + 0xb2d72 (0x04c77d72)
libflashplayer.so + 0xb306c (0x04c7806c)
libflashplayer.so + 0x1052df (0x04cca2df)
libflashplayer.so + 0x104a43 (0x04cc9a43)
libflashplayer.so + 0x105237 (0x04cca237)
libflashplayer.so + 0xf9a6a (0x04cbea6a)
libflashplayer.so + 0x1387dc (0x04cfd7dc)
libflashplayer.so + 0x17ca29 (0x04d41a29)
libglib-2.0.so.0 + 0x2b946 (0x00cb8946)
libglib-2.0.so.0 + 0x2b372 (0x00cb8372)
libglib-2.0.so.0 + 0x2e34f (0x00cbb34f)
libglib-2.0.so.0 + 0x2e6f9 (0x00cbb6f9)
libgtk-x11-2.0.so.0 + 0x12b8d4 (0x053c98d4)
nsAppShell::Run()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
XRE_main()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 2440]
main()  [mozilla/browser/app/nsBrowserApp.cpp, line 62]
libc.so.6 + 0x1923c (0x0059a23c)
Status: UNCONFIRMED → NEW
Ever confirmed: true
linux player has been updated to 21.78.
http://labs.adobe.com/downloads/flashplayer9.html
I don't see this anymore with Firefox 2.0.0.1 and Linux Flash Player 9.  However content is still jumbled (perhaps this is just a content problem?).
-> INVALID  consistent with update to flash 9
Status: NEW → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → INVALID
Luke, can you file another bug on the "content jumbling" issue and CC me (ispiked)?
Status: RESOLVED → VERIFIED
Crash Signature: [@ libflashplayer.so]
You need to log in before you can comment on or make changes to this bug.