memory leak dragging bookmark to bookmarks toolbar

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
11 years ago
9 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({mlk})

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
[ Note: this was not fixed by bug 168411. ]

Steps to reproduce:
 1. start firefox with a clean profile, and exit (to get rid of the strange
    first-startup situation)
 2. start firefox with the environment variables needed for leak-gauge
 3. drag the icon at the left edge of the URL bar to the personal toolbar
 4. close the browser window

Actual results:
Leaked outer window a7e4d88 at address a7e4d88.
Leaked inner window a7e9590 (outer a7e4d88) at address a7e9590.
 ... with URI "about:blank".
Summary:
Leaked 2 out of 7 DOM Windows
Leaked 0 out of 36 documents
Leaked 0 out of 3 docshells

Expected results:
no leaks

Observed in:
2006-09-15-04-mozilla1.8
(Reporter)

Comment 1

11 years ago
Unfortunately, I can't reproduce under GC_MARK_DEBUG.
David, if this is 2.x only i suppose we can resolve as a wontfix?
(Reporter)

Comment 3

9 years ago
Yep; not sure whether wontfix or worksforme is more appropriate, but since I didn't actually test trunk, marking wontfix.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.