rendering of <BR>\n inside PRE

VERIFIED INVALID

Status

()

Core
Layout
P3
normal
VERIFIED INVALID
18 years ago
16 years ago

People

(Reporter: André Langhorst, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
b: 2000-04-09-08	
os: win2000

I´m not sure it´s a bug, compare the attached URL mozilla against IE5,
the IE renders it the way I want to view it (looks good) and (I think) mozilla
renders it exactly (looks bad), is that true, if yes this one isn´t a bug and
mozilla renders it ugly but exactly :(

It has something to do with these <BR> tags followed by additional newlines

Comment 1

18 years ago
While it is possible an meaningful to use many HTML elements inside <PRE>,
(for example, <A>), it is neither necessary nor adviseable to use <BR>.
<PRE> stands for preformatted: all that is needed to get a new line is 
to start a new line. 

After removing the <BR>s, the first section ("Sicherheitsdatenblatt") displayed 
properly (as intended) in IE5, NN4.72, and Mozilla 2000-04-09-08-M15 on WinNT.

With the original URL, NN4.72 renders the page the same as Mozilla, with the
extra blank lines. These will not be coming from the <BR> elements, but
from the extra lines they are on. IE must be special-casing newlines
following <BR>, but by definition all newlines in a <PRE> are displayed
as-is.

So no, this is not a bug, Mozilla is following the HTML spec.
Marking INVALID on that basis.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Summary: rendering inside PRE → rendering of <BR>\n inside PRE

Comment 2

18 years ago
Is IE _not_ following the spec?
I confirm that WinIE5 is incorrectly ignoring a linefeed on lines containing 
only <br> inside <pre> blocks.

i.e., IE5 is wrong.

Comment 4

18 years ago
Marking verified invalid.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.