Memory leak after visiting neogaf.com/bugzilla.mozilla.org and going back

RESOLVED DUPLICATE of bug 353022

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 353022
11 years ago
11 years ago

People

(Reporter: Ryuichi KUBUKI, Unassigned)

Tracking

({mlk})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060917 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060917 Minefield/3.0a1

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060917 Minefield/3.0a1 ID:2006091720 [cairo]

Reproducible: Always

Steps to Reproduce:
1. Open the Firefox (My startup home page for this test was http://www.example.com/ but apparently this can be any other web site)
2. Visit http://www.neogaf.com/forum/forumdisplay.php?f=2 by putting it in the URL bar
3. After the page fully loads, press the Back button to go back
4. Exit the browser
Actual Results:  
Leaked inner window 13e0f10 (outer 283b868) at address 13e0f10.
 ... with URI "http://www.neogaf.com/forum/forumdisplay.php?f=2".
Leaked inner window 29c79f8 (outer 283b868) at address 29c79f8.
 ... with URI "http://www.example.com/".
Leaked outer window 283b868 at address 283b868.
Leaked document at address 296e6d8.
 ... with URI "http://www.neogaf.com/forum/forumdisplay.php?f=2".
Summary:
Leaked 3 out of 14 DOM Windows
Leaked 1 out of 40 documents
Leaked 0 out of 6 docshells
(Reporter)

Updated

11 years ago
Depends on: 353090
Keywords: mlk
(Reporter)

Comment 1

11 years ago
Another test case, just replaced the URL to visit with https://bugzilla.mozilla.org/show_bug.cgi?id=353090

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060917 Minefield/3.0a1 ID:2006091720 [cairo]

Leaked inner window 2708588 (outer 25e8160) at address 2708588.
 ... with URI "http://www.example.com/".
Leaked inner window 2802640 (outer 25e8160) at address 2802640.
 ... with URI "https://bugzilla.mozilla.org/show_bug.cgi?id=353090".
Leaked outer window 25e8160 at address 25e8160.
Leaked document at address 28b6920.
 ... with URI "https://bugzilla.mozilla.org/show_bug.cgi?id=353090".
Summary:
Leaked 3 out of 8 DOM Windows
Leaked 1 out of 38 documents
Leaked 0 out of 3 docshells
Summary: Memory leak after visiting neogaf.com and going back → Memory leak after visiting neogaf.com/bugzilla.mozilla.org and going back

Comment 2

11 years ago
Fixed between 2006-09-18-04 and 2006-09-19-04, so this is a dupe of bug 353022.

*** This bug has been marked as a duplicate of 353022 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
No longer depends on: 353090
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.