Bug 353127 (ctrl-z_undo_spell)

CTRL+Z deletes typing not Spell check change

RESOLVED DUPLICATE of bug 312778

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 312778
12 years ago
12 years ago

People

(Reporter: andykillen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

If I type in a sentence and get one of the words wrong in it, Thunderbird tells me.  If I right click to select an alternative spelling, and then click the wrong item I still have an incorrect spelling (all human error).

To undo my human error I press CTRL+Z to "undo".  This does not undo my spell check changes but undoes all of the last typing.  

Reproducible: Always

Steps to Reproduce:
1.create sentence with spelling mistake
2.right click to change spelling to another wrong spelling
3.CTRL-Z to undo, undoes the whole line

Actual Results:  
i.e.

1 (with mistake)) The dag went home
2 (with error)) The god went home
3 (with Ctrl-Z)) 

Try it yourself.  V.annoying as I end up typing much more than I want to...

Expected Results:  
1 (with mistake)) The dag went home
2 (with error)) The god went home
3 (with CTRL-Z)) The dag went home
(Reporter)

Updated

12 years ago
Alias: ctrl-z_undo_spell

Comment 1

12 years ago
works for me on trunk version 3 alpha 1 (20060813) - so it should be fixed in a future release

*** This bug has been marked as a duplicate of 312778 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

12 years ago
Yes it is a duplicate, it should be noted that the problem still exists in release version   1.5.0.7 (upgrade date 18-Sept-2006) 
You need to log in before you can comment on or make changes to this bug.