The html generated by CGI displays as text -- started with 1.5.0.7

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
12 years ago
8 years ago

People

(Reporter: Keith Price, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

When displaying the results of a road information search from the CA Transportation site, it appears as text. This began with 1.5.0.7 (it worked as expected in 1.5.0.6).

File type (in page info) shows text/plain

Reproducible: Always

Steps to Reproduce:
1. http://www.dot.ca.gov/hq/roadinfo/index.htm
2. Type in a highway number (number only) E.G. 5
3. hit enter or search button


Actual Results:  
The result displays as text starting with:
<Content-Type: text/html>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<HTML LANG="ENG">
<HEAD>
<TITLE>Welcome to California</TITLE>
.....
It seems to be a problem in how the content type line is handled

Expected Results:  
A formatted page (i.e. the result that hapens when you save the result as a file and then load it -- or better than that since the images, etc. don't work when you save it locally).

Comment 1

12 years ago
well the content type is served wrong.
when looking at the generated headers it says what it shows -> 

Response Headers - http://www.dot.ca.gov/cgi-bin/roads.cgi

Date: Mon, 18 Sep 2006 16:47:24 GMT
Server: Apache/2.2.2 (Unix) PHP/5.1.4
Content-Type: text/plain
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked

200 OK

check your cgi. it's just serving the wrong content-type. (konqueror for example gets text/plain too). no error in FF for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 2

12 years ago
fyi: that cgi appears to work with GET requests as well as the form from http://www.dot.ca.gov/hq/roadinfo/index.htm which uses a POST.
For troubleshooting with a CLI user-agent it might be easier to do http://http//www.dot.ca.gov/cgi-bin/roads.cgi?roadnumber=5

Definitely a website bug with Firefox as intended and up to spec.  Every page I tried with for that script returned a 'Content-Type: text/plain' header.

Updated

12 years ago
Status: RESOLVED → VERIFIED

Comment 3

12 years ago
I left out a word.  Last comment should read:
Definitely a website bug with Firefox behaving as intended and up to spec.
You need to log in before you can comment on or make changes to this bug.