Javascript:document.forms[0].submit(); doesn't

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Alec Lazarescu, Assigned: jst)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The input field is taller than in other browsers in Mozilla M14 (including NN6 
Preview 1 which is fine!).

Look on the example page and you'll see the design gets screwed up as the table 
cell gets bigger than it should.

Also, the submit button is being ignored, but I'm not sure how to bring up the 
Javascript: window to find out more details so I can post a separate bug.  This 
also works fine in NN6 PR1, BTW.

Comment 1

18 years ago
Using the 2000-04-09-08-M15 nightly binary on WinNT, the <INPUT>s on this page
are the same size as in NN 4.72, although the borders are different. Displayed
by M14, the defects noted do appear.

The submit button is created by this code:
  <a onmouseover="status='Submit'; return true;" onmouseout="status=''" 
  href="Javascript:document.forms[0].submit();"><img 
  SRC="images/btn_login_submit.gif" WIDTH="74" HEIGHT="26" BORDER="0" 
  alt="Submit"></a></td>
and after clicking it Mozilla displays a new blank page with 
  Javascript:document.forms[0].submit();
in the URL bar. I don't know js myself, but that looks like a DOM problem,
or possibly a Form Submission problem.

Resummarizing from "Input field too tall" (not a problem in current build)
to "Javascript:document.forms[0].submit(); doesn't"; passing to "DOM Level 0"

FYI, there is no javascript debug window in Mozilla as yet; you can run
(from the command line) Mozilla -console or Mozilla >logfile.log
to see the messages that appear on the console. In this case:

   failed to set the page title.
   Document http://awl.intellipro.com/ loaded successfully
   Document: Done (4.055 secs)
   WEBSHELL- = 5
   WEBSHELL- = 4
   failed to set the page title.
   Error loading URL http://awl.intellipro.com/
   Document: Done (0.56 secs)
The first document load corresponds to the index page, the second to the 
Javascript:document.forms[0].submit(); URL.
Assignee: rickg → jst
Status: UNCONFIRMED → NEW
Component: HTML Element → DOM Level 0
Ever confirmed: true
QA Contact: petersen → desale
Summary: Input field too tall → Javascript:document.forms[0].submit(); doesn't
(Reporter)

Comment 2

18 years ago
Ok, I commented out the "event" code cause Mozilla M14 didn't seem to like that 
and it was in the error log.  Then I reran it and got the following at the 
bottom of the error log (plus it didn't load a blank page for me nor do 
anything when I clicked on the submit button).

Lost focus.
WEBSHELL- = 6
WEBSHELL- = 5
Lost focus.
WEBSHELL- = 4
WEBSHELL- = 3
WEBSHELL- = 2
WEBSHELL- = 1
Hey : You are in QFA Shutdown 
XXX WARNING: Number of webshells being leaked: 1
(Assignee)

Comment 3

18 years ago
The problem here is that in the content model the select is not a child of the
form so calling "submit()" in the select elements event doesn't work, I got this
hacked up to work by always setting the script object parent on select elements
in to their form, and not to their actual parent. I don't have time to clean
that up now tho...
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Comment 4

18 years ago
Oops, wrong bug, ignore my last comment.
(Assignee)

Comment 5

18 years ago
This seems to work for me now, marking WORSFORME
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
Apparently both issues fixed in M15.

Agreed RESOLVED

Comment 7

18 years ago
Reporter agreed its resolved. 
Tested it with 2000-060809. Marking VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.