menu lists crash when accessed: bookmarks, prefs, etc.

VERIFIED DUPLICATE of bug 34783

Status

()

Core
XUL
P1
critical
VERIFIED DUPLICATE of bug 34783
18 years ago
10 years ago

People

(Reporter: esther, Assigned: David Hyatt)

Tracking

({pp})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using build 2000-04-10-09 on win98, I crash when selecting a different identity 
for the From field.  (did not happen on linux, still waiting for mac build)

1. Launch Messenger  (have at least 2 mail accounts set up)
2. Select File|New|Message
3. Click on the down arrow in the From field 
4. Select the 2nd account identity 
Result: Crash 
Expected: The from field to display the 2nd identity.

Talkback report coming soon.

Comment 1

18 years ago
Need this on M15 radar.
Keywords: dogfood
Target Milestone: --- → M15
adding me to the cc list as I changed the From picker from html-select to 
menulist recently.  I'm not getting the crash on my build from this weekend.
(Reporter)

Comment 3

18 years ago
Talkback id 8378178
 Call Stack:    (Signature = nsXULElement::HandleDOMEvent 83f623af) 
     
   nsXULElement::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3223]
     
   nsXULElement::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3285]
     
   nsXULElement::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3285]
     
   nsXULElement::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3285]
     
   nsXULElement::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3285]
     
   nsXULElement::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3285]
     
   nsXULElement::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3285]
     
   nsXULElement::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3285]
     
   nsXULElement::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3285]
     
   nsEventStateManager::SendFocusBlur 
                                       
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
2148]
     
   nsEventStateManager::SetContentState
                                       
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
1957]
     
   nsXULElement::SetFocus 
                                       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 4188]
     
   nsEventStateManager::PreHandleEvent 
                                       
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
422]
     
   PresShell::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3439]
     
   nsView::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 811]
     
   nsViewManager2::DispatchEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1354]
     
   HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
     
   nsWindow::DispatchEvent 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 502]
     
   nsWindow::DispatchWindowEvent 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 519]
     
   nsWindow::DispatchFocus 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3284]
     
   nsWindow::ProcessMessage 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2423]
     
   nsWindow::WindowProc 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 677]
     
   KERNEL32.DLL + 0x363b (0xbff7363b) 
                                        
     
   KERNEL32.DLL + 0x242e7 (0xbff942e7)

Comment 4

18 years ago
Hmm I can't seem to trigger the trash either. from esther's talkback report I'd
say a dom event is going to the menu list which is getting destroyed after I
select the identity i want.

Comment 5

18 years ago
I'm not crashing either.
possible opt vs. debug (uninitialized memory problem?)
(Reporter)

Comment 7

18 years ago
I tried this on 3 other systems in our group (all NT 4.0) and they don't crash. 
I then tried this on a win98 system in the lab and it crashes.   This looks to 
be a win98 system only bug (I'll try on win 95 too if it's necessary).
(Reporter)

Comment 8

18 years ago
Suresh confirms is crashes on win95 too.  
oh great, I don't have a Win95/98 machine. I need to find one with a dev 
environment already installed on it...
Status: NEW → ASSIGNED
(Reporter)

Comment 10

18 years ago
Reassigning this to Trudelle, per investigation that this is in the layout/xul 
not specific to mailnews.  Other menulists crash too:  
Bookmarks|Manage Bookmarks|under Bookmark properties the Schedule menulists
Prferences|Appearances|Fonts menulists
Assignee: ducarroz → trudelle
Status: ASSIGNED → NEW
The crash occurs also when changing the font in the pref panel 
(Appearance/Fonts/Fonts for), this one isn't a xul menulist element but an html 
select. 

I am able to reproduce the crash on a Mac debug build from the end of last week 
(Thursday or Friday). It crash in nsLineBox::IndexOf(), aparently because frame 
is not a valid address. Also n=3162360!!

The stack trace is:
...
JavaScript 0x16B98F04
HTMSelectElementRemove
nsHTMLSelectElement::Remove
nsHTMLSelectElement::RemoveChild
nsGenericElement::doRemoveChild
nsHTMLSelectElement::RemoveChildAt
nsGenericHTMLElement::RemoveChildAt
nsXULDocument::ContentRemoved
PreShell::ContentRemoved
StyleSetImpl::ContentRemoved
nsCSSFrameConstructor::ContentRemoved
FrameManager::RemoveFrame
nsBlockFrame::RemoveFrame
nsBlockFrame::DoRemoveFrame
nsLineBox::IndexOf
   frame->GetNextSibling(&frame) ==> CRASH

Comment 12

18 years ago
Correcting product and updating summary.  Since reassigned to trudelle, clearing 
target milestone so trudelle can assign.
Component: Composition → XP Toolkit/Widgets: Menus
Keywords: pp
Product: MailNews → Browser
Summary: [PP]win32 only-crash selecting a different From identity. → menu lists crash when accessed: bookmarks, prefs, etc.
Target Milestone: M15 → ---

Comment 13

18 years ago
.
Assignee: trudelle → pinkerton
QA Contact: lchiang → sairuh

Comment 14

18 years ago
occurs on Win98/Win95 only
Assignee: pinkerton → trudelle

Comment 15

18 years ago
reassign to hyatt (for starters) as p1 for M15
Assignee: trudelle → hyatt
Priority: P3 → P1
Target Milestone: --- → M15


*** This bug has been marked as a duplicate of 34783 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 17

18 years ago
Verified as duplicate.
Status: RESOLVED → VERIFIED

Comment 18

18 years ago
Esther - the bug that this was marked a dup of is marked fixed in M15.  Can you
try this on M15 to see if you crash?


Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.