Thunderbird doesn't handle properly the background attribute on TD and TABLE

RESOLVED DUPLICATE of bug 277925

Status

RESOLVED DUPLICATE of bug 277925
12 years ago
12 years ago

People

(Reporter: intendentedelleacque, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If you insert, from Insert --> HTML, a TABLE with the attribute "background" or a TD tag with the attribute "background", you will have the image displayed while you're composing, but when you'll save as draft/send the image background is lost.

This happens because Thunderbird doesn't attach the image and doesn't convert the path in the "background" attribute, that remains "file:///<path of the image>".

I know that the "background" attribute is not w3c standard, but it's supported by Thunderbird while you're composing and this can "trick" the user that believes that the image will be properly displayed also by the recipient.




Reproducible: Always

Steps to Reproduce:
1. insert from Insert --> HTML a table with the attribute "background" that points to a image file. The image will be displayed while you go on composing.
2. Save as a draft or send

Actual Results:  
The background image is lost and in the source code you'll find still the attribute "background" equal to "file:///<path to the image>"

Expected Results:  
The image should be attached to the mail and the attribute "background" should have the value "cid:" to point to the attached image

Note that it's impossible to use an inline style as workaround, because Thunderbird seems not to handle it.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 277925 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.