Closed Bug 353328 Opened 15 years ago Closed 13 years ago

we would like to replace the searchengine marktplaats.nl for ebay in nl and fy-NL

Categories

(Mozilla Localizations :: nl / Dutch, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: fryskefirefox, Unassigned)

References

Details

Attachments

(5 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.7.12) Gecko/20050915

Ebay is typically a very global online store. Sometime ago they bought the Dutch version called www.marktplaats.nl. Since this is a more local version of Ebay we would like to replace this one with www.marktplaats.nl.

Reproducible: Always




The according .xml file will be added in reply to this bug.
Assignee: nobody → dutch.nl
Component: Search → nl-NL / Dutch
Product: Firefox → Mozilla Localizations
QA Contact: search → dutch.nl
Attachment #239177 - Flags: approval1.8.1?
Comment on attachment 239177 [details]
searchengine for marktplaats.nl

Too late for 2.0. Please renominate at a later phase for 2.0.0.1 or 3.0.

Mic's OK is in bug 348095, though that's brief.
Attachment #239177 - Flags: approval1.8.1? → approval1.8.1-
(In reply to comment #2)
> (From update of attachment 239177 [details] [edit])
> Too late for 2.0. Please renominate at a later phase for 2.0.0.1 or 3.0.
> 
> Mic's OK is in bug 348095, though that's brief.
> 

i thought we where only waiting for a ok from marktplaats to mozilla but that is was approved allready. can we get this in for RC2?
hey,
the challenge is to ensure marktplaats.nl is OK to receive our traffic. so i can approve it in principle but not in reality until they indicate in some way that we won't break their servers by sending them our traffic and therefore are willing and maybe even want to receive our traffic.
make sense?
thanks
mic
what is the status of this bug, did markplaats approve this?
Mic, I'm not sure your comment 4 is clear on who's supposed to reach out to markplaats.nl here, I bet you know.
hi guys
i'm very sorry that this lagged so long. if i ever miss anything like this in the future again, please don't hesistate to ping me directly (of course I try to avoid that too :-)
I will contact Marktplaats now and post back in the bug once I receive approval
mic
Hi
I tried to contact Marktplaats but haven't received a response. Tim, can you try it may be a language issues. This is the email I sent my request to: info@marktplaats.nl 
Can you please ping them and ask them to email us with permission to put their search plug in within Firefox
thanks
mic
(In reply to comment #8)
> Hi
> I tried to contact Marktplaats but haven't received a response. Tim, can you
> try it may be a language issues. This is the email I sent my request to:
> info@marktplaats.nl 
> Can you please ping them and ask them to email us with permission to put their
> search plug in within Firefox
> thanks
> mic
> 
Ward Meijer of Markplaats will comment in these bug.
Hi all,

My name is Ward Meijer, Head of Internet Marketing for marktplaats.nl and ebay.nl.
I spoke to Tim Maks, and I'm excited to hear about your plans to integrate marktplaats.nl in the Firefox browser.
I would appreciate an email with screenshot of the planned look & feel (can you send me one of the present situation inclusing ebay as well)? Can you feature both ebay.nl and marktplaats.nl?
To allow us to track the results (like clicks and number of placed advertisements) of the link to Marktplaats.nl, we'll provide a URL (that enables Mediaplex tracking). Please contact my colleague Andres Boot via aboot@ebay.com or telephone +31 6 29511279 for the correct link.

Please let me know if you need more info.

Regards,

Ward Meijer
Head of Internet Marketing
eBay.nl / Marktplaats.nl
T: +31 20 4622 549
M: +31 6 15905507
wmeijer@ebay.com (wmeijer@marktplaats.nl is redirected to this address)
Skype: ward.m

Hello Ward,
my understanding is ebay.nl and marktplaats.nl are very similar in functionality therefore we will only feature one.
i'm sure Tim can help with the screen shot, Tim? if not, i'll provide one shortly
I need to verify the URL you're talking about using would be ok with our privacy policies for users - i'll get back to you on this. Then I'll email aboot@ebay.com for the correct url.
thanks
mic
Hi
further to my comment #11
"my understanding is ebay.nl and marktplaats.nl are very similar in
functionality therefore we will only feature one." 
what i meant by functionality was in the features, functions and user experience. 
if you (localizer team, ward, etc) feel differently, please let me know.

on privacy policies - can one of you verify that Marktplaats.nl has a clear privacy policy for users and in that policy it indicates what you are using the data you would collect for?

LMK if you have any questions above this. my nic in IRC is mic and i'm usually in the l10n channel at least

thank you
mic

Hi,

I'd like to see a link to both platforms, are Marktplaats.nl and eBay.nl are positioned and perceived differently in NL by our customers. Marktplaats is our classifieds platform, used by our customers for mainly national trade and where the transactions take place off the platform (between users themselves). Bids made are non-binding. eBay in contrast is used for international trade, and is an auction site, where the bids are binding and the transaction takes place on the platform. Customers therefore use the platforms for different reasons, and both belong to the biggest platforms in the Netherlands.

As for privacy policies, there is a clear policy, accessible via the link at the bottom of the Marktplaats.nl pages: http://statisch.marktplaats.nl/help/beleidenvoorwaarden.html

Regards,
Ward
here are 2 screenshots of the marktplaats searchplugin
Ward re comment#13
according to original bug348095 comment #3
really we use the list to demonstrate to the user functionality and then give them choice to add if they wish. so they can always add ebay.nl in addition to marktplaats.nl
 i have talked with localizers again and based on our guidelines I am saying one plug in - per bug348095 it should be marktplaats.nl

do i still need to verify the url from aboot?

thanks
mic
Status: NEW → ASSIGNED
As being the original poster of this bug, I also want to mention that the Frisian (fy-NL) team is also considering to add marktplaats to their searchmachines.
Maybe Ward Meijer wants to create a separate link to marktplaats.nl for the Frisian version for tracking purposes, if possible using Leeuwarden as the start city with a start range of 50 kilometers.
Regards,
Wim
Presuming there are no worldwide firefox-ebay agreements about featuring ebay links in all firefox browsers, I do appreciate the marktplaats.nl links in both the Dutch and Frisian versions of the firefox internet browsers.
Please request the appropriate URL from Andres Boot via aboot@ebay.com.

Ps. can you send me screenshots in advance via wmeijer@marktplaats.nl ?

Ward
(In reply to comment #18)

> Ps. can you send me screenshots in advance via wmeijer@marktplaats.nl ?
> Ward

the screenshots are allready attached to this bug
waiting on change to url - should be markplaats url not media plex
Whiteboard: needs-mic
Please add www.marktplaats.nl to the future release of the Dutch Firefox.
Can I receive some screenshots?
The mediaplex URL was intended to tell us how much traffic we receive from the browser. Is there another way you can provide us with that data?
Ward
I have committed the searchplugin to the trunk.
for our records:

----- Original Message -----
From: "Axel Hecht" <l10n@mozilla.com>
To: "tim maks" <tim_maks@planet.nl>
Cc: "Ward Meijer" <wmeijer@ebay.com>, "Michal Berman" <mic@mozilla.com>, "Andres Boot" <andres.boot@ebay.com>
Sent: Friday, February 1, 2008 11:02:25 AM (GMT-0500) America/New_York
Subject: Re: Firefox url for search plug in

Hi,

interpolating between the two, I think we should use

http://www.marktplaats.nl/nieuw_zoek.php3?client=firefox&q={searchTerms}

or, in MozSearch XML:

<Url type="text/html" method="GET"
      template="http://www.marktplaats.nl/nieuw_zoek.php3">
  <Param name="client" value="firefox"/>
  <Param name="q" value="{searchTerms}"/>
</Url>

Tim, please provide a patch this time before checking in. We should add 
a SearchForm, too. Without params, IMHO, just http://www.marktplaats.nl/

The other url for searching seems to be 
http://kopen.marktplaats.nl/search.php?client=firefox&q={searchTerms}

I'm not sure if either of those URLstrigger the right tracking on 
marktplaats, though.

Axel
Attached patch patch to the new url (obsolete) — Splinter Review
Attachment #302111 - Flags: review?
Attachment #302111 - Flags: review? → review?(gavin.bugzilla)
Comment on attachment 302111 [details] [diff] [review]
patch to the new url

Hi Tim,

That patch doesn't seem to match either of the URLs in Mic's comment 24. It uses the host from the second, but with a different "client" parameter, and you seem to have replaced "{searchTerms}" with just "keyword", which won't work.

(Note: please use "gavin.sharp" rather than "gavin.bugzilla" when requesting review.)
Attachment #302111 - Flags: review?(gavin.bugzilla) → review-
Comment #27 has been made private (hidden from public view) because it contains private information relating to a Mozilla contributor.

Tim: can you please repost the contents of comment #27 without the personal information?

Thanks,

Gerv
> Axel Hecht schreef:
>> Cool. When you attach a patch, request review from gavin? 
>> Axel
>>
>> tim_maks@planet.nl wrote:
>>> Looking good, i will make a patch later this day.
>>>  
>>> Tim Maks
>>>
>>> ------------------------------------------------------------------------

>>>
>>> awesome, i think that looks good. straight forward, doesn't appear to me to be confusing to user.
>>> Axel/Tim - any concerns for you?
>>> mic
>>>

>>>
>>>
>>>
>>>
>>> Hello Mic,
>>>
>>>
>>>
>>> I discussed with our tech people.
>>>
>>>
>>>
>>> Can you use this link:
>>>
>>>
>>>
>>> kopen.marktplaats.nl/search.php?q=keyword&client=firefox-search
>>>
>>>
>>>
>>> Than we can implement a tracking pixel in search.php
>>>
>>>
>>>
>>>
>>> Kind Regards,
>>> Andres Boot
>
>
(In reply to comment #29)
> >>> Can you use this link:
> >>> kopen.marktplaats.nl/search.php?q=keyword&client=firefox-search

OK, that's fine. You'll still need to replace "keyword" with "{searchTerms}" if you want the engine to actually work, and not always search for the string "keyword" :)
replaced "keyword" with "{searchTerms}" and added <SearchForm>http://www.marktplaats.nl</SearchForm> as suggested by pike
Attachment #302111 - Attachment is obsolete: true
Attachment #302386 - Flags: review?(gavin.sharp)
Whiteboard: needs-mic → needs-gavin
Comment on attachment 302386 [details] [diff] [review]
markplaats patch 2

>Index: marktplaats-nl.xml

>+<Url type="text/html" method="GET" template="http://kopen.marktplaats.nl/search.php?q={searchTerms}&amp;client=firefox-search ">

Nit: please remove the space at the end of this line.

(It would also be clearer to use <Param> elements rather than embedding them directly in the template, but that's not a big deal.)
Attachment #302386 - Flags: review?(gavin.sharp) → review+
Whiteboard: needs-gavin
Committed the patch to the trunk,

Wim can you commit this patch also for fy-NL so we can close these bug?
Committed into the fy-NL trunk also as of now.
Thanks everybody!
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Tonnes on IRC pointed out that the encoding for the engine description wasn't quite right. I committed a fix to the nl and fy-NL plugins to fix this (use UTF-8).

l10n/fy-NL/browser/searchplugins/marktplaats-fy-NL.xml 	1.3
l10n/nl/browser/searchplugins/marktplaats-nl.xml 	1.4 
Component: nl-NL / Dutch → af / Afrikaans
Component: af / Afrikaans → nl-NL / Dutch
(In reply to comment #36)
> Tonnes on IRC pointed out that the encoding for the engine description wasn't
> quite right. I committed a fix to the nl and fy-NL plugins to fix this (use
> UTF-8).
> 
> l10n/fy-NL/browser/searchplugins/marktplaats-fy-NL.xml  1.3
> l10n/nl/browser/searchplugins/marktplaats-nl.xml        1.4 
> 

Thanks, at some reason Kate save (sometimes) files in iso8859-1 instead of utf-8, i forgot to check it. 
Blocks: fx3-l10n-nl
You need to log in before you can comment on or make changes to this bug.