component in enter_bug is case sensitive

RESOLVED FIXED in Bugzilla 5.0

Status

()

Bugzilla
Creating/Changing Bugs
--
minor
RESOLVED FIXED
12 years ago
6 years ago

People

(Reporter: Henrik Gemal, Assigned: Koosha KM)

Tracking

unspecified
Bugzilla 5.0
Bug Flags:
approval +

Details

Attachments

(1 attachment)

Comment 1

12 years ago
Yeah, this is because JavaScript is case-sensitive and MySQL is not.
Severity: normal → minor
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 2

6 years ago
Created attachment 651526 [details] [diff] [review]
patch - v1
Attachment #651526 - Flags: review?(glob)
Comment on attachment 651526 [details] [diff] [review]
patch - v1

r=glob
Attachment #651526 - Flags: review?(glob) → review+
Assignee: create-and-change → koosha.khajeh
Flags: approval?
Target Milestone: --- → Bugzilla 4.4

Updated

6 years ago
Flags: approval? → approval+
(Assignee)

Updated

6 years ago
Status: NEW → ASSIGNED

Comment 4

6 years ago
Ah no, wait. The .lower virtual method only exists since TT 2.24, but we require 2.22. So for 2.22 and 2.23, this method is not recognized and the last element from the select field is always selected.
Flags: approval+ → approval?

Updated

6 years ago
Flags: approval?

Comment 5

6 years ago
Comment on attachment 651526 [details] [diff] [review]
patch - v1

If we want to use .lower, we have to require TT 2.24. But it's not OK to require 2.24 for Bugzilla 4.4, because it was released a few months ago only, and many distros don't have it yet.
Attachment #651526 - Flags: review-

Updated

6 years ago
Target Milestone: Bugzilla 4.4 → Bugzilla 5.0
(Assignee)

Comment 6

6 years ago
Well, if you're going to include this change in 5.0, why r-? Or, if r-, why 4.4 -> 5.0?! :-)

Comment 7

6 years ago
(In reply to Koosha Khajeh Moogahi [:koosha] from comment #6)
> Well, if you're going to include this change in 5.0, why r-? Or, if r-, why
> 4.4 -> 5.0?! :-)

Your patch must also change the min version of Template::Toolkit in Bugzilla/Install/Requirements.pm, which is why I r- your patch.

We are going to release Bugzilla 4.4 soon, and TT 2.24 is too recent to require it in 4.4, which is why I retargetted this bug to 5.0. For 5.0, I'm fine to require TT 2.24 as this will also fix https://rt.cpan.org/Public/Bug/Display.html?id=47929. mkanat said in bug 372979 comment 16 that Bugzilla was affected by this problem when a vote confirms a bug, but I just tried and I cannot reproduce his issue.

Comment 8

6 years ago
Comment on attachment 651526 [details] [diff] [review]
patch - v1

Bugzilla 5.0 now requires TT 2.24 thanks to bug 812220, so this patch is now fine.
Attachment #651526 - Flags: review-

Updated

6 years ago
Flags: approval+
(Assignee)

Comment 9

6 years ago
Someone commit this, please.

Comment 10

6 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/bug/create/create.html.tmpl
Committed revision 8532.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.