TB Update fails if the new mail tray icon is displayed

VERIFIED DUPLICATE of bug 340535

Status

Thunderbird
General
--
critical
VERIFIED DUPLICATE of bug 340535
12 years ago
12 years ago

People

(Reporter: Ben Lerner, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

TB automatically downloads updates as appropriate, which is fine.  But if I've been away from the computer for a while, and have new mail messages available, then I'll see both the tray icon and the Software Update window suggesting I restart TB.  If I do, TB fails to exit properly, as the icon isn't cleaned up.  I have to kill TB from the Task Manager, and when I restart TB, the update fails, since the profile is still in use by Windows.  I need to reboot Windows and restart TB twice -- the first restart fails but unlocks the profile, and the second restart will actually apply the update and succeed.

Reproducible: Always

Steps to Reproduce:
1. Have an out of date TB.
2. Get new mail, such that the tray icon is visible
3. Wait for Software Update to download and suggest you restart.
4. Restart TB.  This will fail.
5. Kill thunderbird.exe and restart it.  The update will fail.

Actual Results:  
The tray icon doesn't disappear, and thunderbird.exe doesn't terminate.

Expected Results:  
Thunderbird should exit cleanly, restart, and apply the update.

I'm marking the bug as critical because the program does hang, and when next you restart it, it fails to start correctly and locks you out of your data.  You need to reboot Windows and repeatedly restart TB to get back into your profile.
You don't run into a infinite loop like I described in bug 340535? When the update fails could you attach following file?

C:\Programme\Mozilla Thunderbird\updates\last-update.log

So we could see why it is not updated correctly.
(Reporter)

Comment 2

12 years ago
Sorry! I searched but didn't see your bug before I opened this one.  Yes, I get that same infinite-restart behavior as well, though I've only noticed it occur on 1.5.0.x versions when the new mail icon was displayed.  To clarify my step 4 below, when I said fail, I meant the update will fail and when I press OK then TB restarts and fails again etc.etc. until I kill thunderbird.exe from the Task Manager.  Then the new mail icon goes away, thunderbird is closed, and then my workaround below succeeds.

I no longer have the last-update.log file which shows the error; the workaround I described succeeded at the patch, and I needed email access more than I remembered to save the update log :-p  

Not sure if this is relevant -- when I restarted Windows and looked in my profile directory, I still had a profile.lock file there; after the first restart of TB, that file was deleted, and so the second update could get in and succeed.  I think that's just an artifact of TB not being closed properly.

Right now, I don't have a system which I can readily revert TB on to a prior version and re-update, but I'll try to get my hands on one soon.  In the meantime, I am marking this as a duplicate of your bug -- thanks for pointing it out!

*** This bug has been marked as a duplicate of 340535 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.