Download manager won't resume

RESOLVED DUPLICATE of bug 230870

Status

()

--
critical
RESOLVED DUPLICATE of bug 230870
13 years ago
11 years ago

People

(Reporter: SteveWen89, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

I've been trying to download America's Army 2.7 for a week now.  It's a 2.49GB file and at 60kb/s it takes 12 hours, right around 6 hours after the download starts my internet always seems to go down.  On the download manager is just freezes how much time was left and how fast it was downloading at the time, so so I try pausing it and restarting and it says it can't find the file that I can easily see sitting on my desktop.  I really want the game but with Firefox I can never get it.

Reproducible: Always

Steps to Reproduce:
1.Start downloading America's Army 2.7
2.Disconnect the internet(I haven't tested it by purposely disconnecting)
3.Attempt to resume download

Actual Results:  
Couldn't resume the download and got an error that it couldn't find the file that was sitting on my desktop.

Expected Results:  
It should have found the file and tried to continue my download.

Comment 1

13 years ago
Reporter: Does it happen with all downloads?  Or just with "America's Army"?  If it just happens with "America's Army", could you give us a link for testing?  In the meantime, please retest with new profile and newest nightly.

For me:

1. Start a download.
2. Disconnect Internet connection in the middle of the download.

Result for me:

Download manager shows Done and I get a corrupted file.

"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 BonEcho/2.0"

Comment 2

13 years ago
Hopefully, Jeff Walden will get around to fixing this bug sometime in the near future.

*** This bug has been marked as a duplicate of 230870 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
I would suggest using a separate download manager for large files for now.

Unix: aria2 (command line, http://aria2.sourceforge.net/), D4X, or KGet
Windows: GetRight, wxDownload Fast (http://dfast.sourceforge.net/), Free Download Manager, or ReGet
Mac: Speed Download or iGetter
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.