Attachments in an attached message appear as attachments of the main message

RESOLVED DUPLICATE of bug 203570

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 203570
11 years ago
11 years ago

People

(Reporter: Nuno Gonçalo Brito, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

If you open a message containing an attachment which is a message containing attachments then you see all the attachments as if they were attached to the main message instead of to the attached message.

Reproducible: Always

Steps to Reproduce:
1. Create and send a message to yourself.
2. Create and send a second message to yourself containing the first one as an attachment.
3. Create and send a third message to yourself containing the second one as an attachment.
4. Open the received message.
Actual Results:  
You will see 2 attached messages in the attachment panel of the third message

Expected Results:  
I was expecting to see only the second message (the second one) in the attachment panel of the third message.

I was expecting to only see the first message if I opened the second message from the attachment panel of the third message.

Another thing is that when you open any of the attached messages you continue to see both 2 messages in the attachment panel of each message's window but you cannot open any from there. Only from the main message (the third) window are you able to open the other messages.

Microsoft Outlook and Outlook Express don't work this way.

If you have an email containing several messages each one with its attachments then the attachments panel will be a mess and it will be difficult to know which attachment belongs to which message.
(Reporter)

Comment 1

11 years ago
Created attachment 239245 [details]
Screenshot
Dup of Bug 203570.
See Bug 269826 also, and see dependency tree of it.

*** This bug has been marked as a duplicate of 203570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.