Getting error 2147500037 (x 80004005) when importing attached .ics

RESOLVED DUPLICATE of bug 336577

Status

Calendar
Import and Export
RESOLVED DUPLICATE of bug 336577
12 years ago
12 years ago

People

(Reporter: Anli Shundi, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Thunderbird: version 1.5.0.7 (20060909)  Lightning: 2006031011

Lightning 0.1 was able to import a couple of other items but not this one.

Reproducible: Always

Steps to Reproduce:
1. Save given .ics attachment
2 [review]. Calendar/import it

Actual Results:  
1 items failed to import.  The last error was: 2147500037

Expected Results:  
1 item successfully imported or the like
(Reporter)

Comment 1

12 years ago
Created attachment 239248 [details]
can't be imported by Lightning

Updated

12 years ago
Attachment #239248 - Attachment mime type: application/octet-stream → text/plain

Comment 2

12 years ago
(In reply to comment #1)
> Created an attachment (id=239248) [edit]
> can't be imported by Lightning
> 
This is because of the Microsoft timezone ID that they are using. If you notice in the VTIMEZONE block the TZID does not have quotes, but in the DTEND/DTSTART it does have quotes. That's actually invalid, but we should handle it.
This bug is a duplicate of: 336577

*** This bug has been marked as a duplicate of 336577 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.