[RFE] Bugzilla (&&/|| Bugzilla Helper) could sniff if non-Mozilla browser used to report bug

VERIFIED WONTFIX

Status

()

Bugzilla
Bugzilla-General
P3
enhancement
VERIFIED WONTFIX
19 years ago
6 years ago

People

(Reporter: Eli Goldberg, Assigned: justdave)

Tracking

Details

(Reporter)

Description

19 years ago
During the Friday Mozilla Developer meeting's QA breakout session, one of the 
overwhelming complaints was the number of Netscape 6 PR users who are reporting 
bugs into Mozilla.

One possible solution to this was to put an interim step in between clicking on 
the Bugzilla Helper (and possibly the regular bug reporting form) and the actual 
form. Specifically:

	- Sniff the user agent
	- If the user agent is a commercial build, pop up an annoying dialog to the 
effect of, "If you're reporting a bug against Netscape 6, please use the Netscape 
Feedback Center. Only bugs reported against Mozilla builds will be accepted 
here." (Ideally, one of the buttons should enable the user to be redirected to 
the Feedback Center)
	- If the user agent isn't a commercial build, load the requested bug form.

However, if lots of Mozilla contributors use Netscape 6 (whether now, or 5 months 
from now) as their dominant user agent, rather than a Mozilla build, this could 
annoy a lot of people.

Thoughts?

Comment 1

19 years ago
Marking wontfix on terry's behalf. This has been discussed already and
its a bad idea. The point is to keep people from submitting netscape 6
bugs, not to keep them from using netscape 6. 

Also, there are two faulty assumptions here. a) People using netscape 6
are filing bugs against netscape 6. b) people filing bugs against 
netscape 6 are using netscape 6.

I've added a blurb at the top of the bug entry page about netscape 6.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

19 years ago
Really? Can you actually prove that either of these assumptions are faulty?

For the heck of it, I culled through the past 50-60 bugs reported that contain 
the word "Helper", modified in the past day. 

Out of the 6 bug reports that contained a Netscape 6 user agent in that batch:
	- 5 of them were unequivocally Netscape 6 bugs.
	- 1 of them mysteriously was fixed two days later, so it may or may not have 
been NS 6.

I don't claim that this will be consistent with future results, but the only 
evidence I can find fully validates assumption (a). 

I'm not sure how assumption (b) actually matters --- those bugs will be 
unaffected by such a change.

So, I'll accept the WONTFIX resolution, but it's completely counter to the data 
that I've seen firsthand.

Comment 3

19 years ago
updated the bug helper to add a check for "Netscape6" in the user agent
similar to the "Mozilla/4" check that was already there. It adds text to
document shooing commercial build users away but doesn't make the form
inaccessible.

"This is a tool for reporting bugs with the Mozilla web browser from 
mozilla.org. Use the Netscape 6 Feedback Center to report bugs with Netscape 6. 
To file a Netscape 6 bug with this form, please reproduce it first in a recent 
build of Mozilla to make sure the problem hasn't been fixed already."

marking SORTAFIXED

Comment 4

19 years ago
Thank you dawn!  
Thanks - definitely the best solution. :-)

Gerv
Agreed.  Verif.
Status: RESOLVED → VERIFIED
moving all closed Bugzilla bugs to the new Bugzilla product.
This batch is DUPLICATE/INVALID/WORKSFORME/WONTFIX
reassigning to default owner and QA in case of the bug being reopened.
Clearing milestones, since we really shouldn't have them on these types of
resolutions.  Sorry for the spam everyone...
Assignee: terry → justdave
Status: VERIFIED → NEW
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
damn, bit by bug 30731. sorry for the respam...  one more coming to complete the
status fix
Status: NEW → RESOLVED
Last Resolved: 19 years ago17 years ago
completing status fix...
Status: RESOLVED → VERIFIED

Comment 10

16 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.