Junk manual mark of not-the-current message selects wrong next message

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: hacksaw, Unassigned)

Tracking

(Blocks: 1 bug)

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Thunderbird version 1.5.0.7 (20060909)

Looking at a load of spam, junk filtering missed a few. I don't need to look at 'em, it's obvious. I toggle the icon in the column. 

Mean while the current message is somewhere way up, off the page, 'cause there's a *lot* of spam.

As soon as I click on the column icon, marking that message as junk, my screen jumps to center on the (new) currnet message selection.

If I am modifying the status of something other than the current message, I expect the current message to change not at all.



Reproducible: Always

Steps to Reproduce:
1. Pick a message other than the current message. Leasve the current message selected
2. In the junk status column, click to set the status of the message to junk
3.

Actual Results:  
Current message highlighting moves down, new message is displayed.

Expected Results:  
Current message should not change. Message you are marking should merely get marked, and maybe go some place if you have that preference set. (I don't)
(Reporter)

Comment 1

12 years ago
The bug seems to be specific to the Intel Mac OS X.
Version: unspecified → 1.5

Comment 2

11 years ago
hacksaw, do you see this in version 2?

WFM windows trunk 0822
Whiteboard: CLOSEME 09/08
(Reporter)

Comment 3

11 years ago
It's sort of gone. It doesn't move the marker now, but it does focus the marker if it's off the screen. So the second part of the behavior is changed, but not the first part.

Comment 4

11 years ago
Ludovic, do you see this?
Assignee: mscott → nobody
Whiteboard: CLOSEME 09/08

Comment 5

11 years ago
you tested windows?  (or linux)
(Reporter)

Comment 6

11 years ago
I haven't tested windows, I don't use thunderbird on it. Notably, I don't see the behavior on PPC Mac. I don't use thunderbird much on Linux.

Comment 7

11 years ago
if works on Mac then => WFM. Thanks for the feedback.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

11 years ago
No. I called it PPC Mac for a reason. It still doesn't work all the way, as I note in comment #3 on Intel Mac.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

11 years ago
Still seen in version 2.0.0.9 (20071031) on Intel Mac OS X 10.4.11

Comment 10

11 years ago
any similarity to bug 324188?
(Reporter)

Comment 11

11 years ago
Could be. I wouldn't be shocked if the problem were in the same bit of code. However, the nuances are different.

The other bug is complaining that if you have "remember last selected message" checked, it shouldn't select a message.

Mine says, if you toggle a bit on the screen, that shouldn't change the selection or change the focus. I suspect the algorithm is saying "if junk bit twiddled, see if we are supposed to delete it, and do the user appropriate routine there, then reflow the screen. And reflow the screen is probably taken as set the goal line to the selected message, and write out the header lines appropriate for the window.

Reflow, if it is like this, wants to have a partner that doesn't change the goal line at all. Don't move the message you just twiddled up or down, just mark it, or close up around it, depending on the user preference of mark versus delete.

Comment 12

9 years ago
And additional information here, hacksaw?  Still occurring on latest release build, and how about on the new 3.x pre-release builds?

Comment 13

7 years ago
no reply to comment 12, so incomplete
if you still see this problem them please comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 14

7 years ago
Now updated to version 10. The problem appears fixed. Thanks!

Updated

7 years ago
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.