SVG image has no horizontal scrollbar

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Assigned: jwatt)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

I saw this while testing Bug 353450; the image in attachment 239300 [details] of Bug 353450 has no horizontal scrollbar in trunk. Branch displays the scrollbar.

Regression between 1.9a1_2006031504 and 1.9a1_2006031521:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2006-03-15+03%3A00&maxdate=2006-03-15+22%3A00

Caused by Bug 192767?
(Reporter)

Updated

12 years ago
Keywords: regression
Created attachment 239542 [details] [diff] [review]
patch

There are so many testcases in bug 192767 I found it rather hard to tell if I've broken any of them.
Assignee: general → longsonr
Status: NEW → ASSIGNED
Attachment #239542 - Flags: review?(dbaron)
Keywords: testcase
If the comment says it doesn't matter, why does it matter?  In what cases is the comment wrong?  SVG only, or others?  Have you tested those others?
Created attachment 247358 [details]
simplified testcase

2000x2000 px svg, the horizontal scrollbar fails
Comment on attachment 239542 [details] [diff] [review]
patch

marking review- pending answer to question
Attachment #239542 - Flags: review?(dbaron) → review-
Sorry for the delay responding to the question. I have looked into this further and since image frames work OK, perhaps this would be fixed by implementing bug 288276 comment 22 rather than the change I originally proposed. I'm going to look at doing things that way when I have time and see if scrolling then comes out in the wash.
Assignee: longsonr → general
Status: ASSIGNED → NEW

Updated

11 years ago
Duplicate of this bug: 374223

Updated

11 years ago
Flags: blocking1.9+

Updated

11 years ago
Duplicate of this bug: 384545

Updated

11 years ago
Duplicate of this bug: 385833
(Assignee)

Updated

11 years ago
Assignee: general → jwatt
(Assignee)

Comment 10

11 years ago
Created attachment 278970 [details] [diff] [review]
patch
Attachment #239542 - Attachment is obsolete: true
Attachment #278970 - Flags: review?(bzbarsky)
(Assignee)

Comment 11

11 years ago
I'm not sure about the FinishAndStoreOverflow calls. It's unclear to me from that method's documenting comment under what circumstances you should or shouldn't call it. The scrolling is fixed with or without it, but it seems like a good idea to store the size since reflowing to get the size would be horribly expensive. Also there's unlikely to be that many nsSVGOuterSVGFrame objects per document.
Status: NEW → ASSIGNED
Comment on attachment 278970 [details] [diff] [review]
patch

In your case you never have overflow, so it doesn't matter much whether you cann FinishAndStoreOverflow... but it's the Right Thing To Do.

r=bzbarsky, but get roc to sr, ok?
Attachment #278970 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 13

11 years ago
Comment on attachment 278970 [details] [diff] [review]
patch

Sure thing. Thanks Boris.
Attachment #278970 - Flags: superreview?(roc)
Comment on attachment 278970 [details] [diff] [review]
patch

this is OK. However, I actually think nsSVGOuterSVGFrame should calculate its overflow area as the bounding box of its descendants. Another time.
Attachment #278970 - Flags: superreview?(roc) → superreview+
(Assignee)

Comment 15

11 years ago
Checked in. I added a comment to that effect.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
The comment should use "in principle" rather than "in principal"
(Assignee)

Comment 17

11 years ago
Oops.
You need to log in before you can comment on or make changes to this bug.