shop.usps.com - after going back, JavaScript page number links stop working

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
12 years ago
3 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
If you click Buy next to a product in the USPS shop, then hit page back in the toolbar, the numbered page links at the top of the window stop working.  These try to run JavaScripts but don't appear to do anything at all.  They work until you do this.
(Reporter)

Comment 1

12 years ago
This also happens in Firefox 1.5.0.7, by the way.

Comment 2

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060920 Minefield/3.0a1

I can reproduce this, too. It only happens when bfcache is enabled.
Component: General → History: Session
OS: Mac OS X 10.3 → All
Product: Firefox → Core
QA Contact: general → history.session
Hardware: PC → All
Summary: After hitting previous page button in toolbar, some links at shop.usps.com stop working → After going back, some JavaScript links at shop.usps.com stop working
Version: 2.0 Branch → 1.8 Branch

Comment 3

12 years ago
I changed the URL to a page where this is reproducible using the steps in comment 0.
Ok, the buy links, typically use this:
onclick="Add2ShopCart(document.getElementById('OrderItemAddForm_2')); return false;"


function Add2ShopCart(form)
{
	if (!busy) 
	{
		busy = true;
		form.action.value="OrderItemAdd";
		form.URL.value="OrderCalculate?URL=OrderItemDisplay";
		form.submit();
	}
}


The numbered links, typically use this: javascript:processSearchForm(document.CatalogSearchResultForm,6)

var busy = false;
function processSearchForm(form, beginIndex)
{
	if (!busy){
	  busy = true;
	  form.beginIndex.value = beginIndex;
	  form.pageSize.value = 6;
	  form.submit();
	}
}

So after going back, busy is still true, because of bfcache that value is cached.

Comment 5

12 years ago
Moving over to Tech. Evanglism.
Assignee: nobody → english-us
Component: History: Session → English US
Product: Core → Tech Evangelism
QA Contact: history.session → english-us
Summary: After going back, some JavaScript links at shop.usps.com stop working → shop.usps.com - after going back, JavaScript page number links stop working
Version: 1.8 Branch → unspecified

Comment 6

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.