Crash when loading jpg image

RESOLVED DUPLICATE of bug 210931

Status

()

--
critical
RESOLVED DUPLICATE of bug 210931
12 years ago
12 years ago

People

(Reporter: ron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; da-DK; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; da-DK; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text

Firefox crashes when loading http://hugin.sourceforge.net/tutorials/scans/scan-1-small.jpg (linked from http://hugin.sourceforge.net/tutorials/scans/en.shtml).



Reproducible: Always

Steps to Reproduce:
1. Open http://hugin.sourceforge.net/tutorials/scans/scan-1-small.jpg
2.
3.

Actual Results:  
Firefox crashes

Expected Results:  
Display the image

I have also tested firefox 2.0b2 [Mozilla/5.0 (X11; U; Linux i686; da; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2] with the same result.

Here is the output from the command line:

[firefox@jupiter firefox]$
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 40356 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

[1]+  Exit 1                  ./firefox
Image is 325x525 pixels, 1366991 bytes. This is another "X can't get enough memory to handle the decompressed JPEG" bug.
Whiteboard: DUPEME

Comment 3

12 years ago
See also bug 321581.

*** This bug has been marked as a duplicate of 210931 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.