RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Aleksej, Assigned: yuanyi21)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

27.30 KB, application/zip
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060607 Debian/1.7.12-1.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0

When the graph applet loads, the browser becomes unusable.

Same with Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL
2. Wait till the applet loads
Actual Results:  
Crashes completely, not even being able to start Talkback.
Or freezes partially or completely.

Expected Results:  
Say that Java has crashed, and continue to work.

Debian with any kernel

same with Java build 1.5.0_04-b05

An example of console message for 2.0 RC1:
$ ./firefox -P
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0xa1cceef0, pid=27894, tid=2710006704
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_08-b03 mixed mode, sharing)
# Problematic frame:
# C  [libfontmanager.so+0x2eef0]
#
# An error report file with more information is saved as hs_err_pid27894.log
...
INTERNAL ERROR on Browser End: Pipe closed during read? State may be corrupt
System error?:: Success

For 1.5.0.7:
#  SIGSEGV (0xb) at pc=0xa1d8db70, pid=28407, tid=2710789040
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_08-b03 mixed mode, sharing)
# Problematic frame:
# C  [libfontmanager.so+0x2eb70]
#
# An error report file with more information is saved as hs_err_pid28407.log


A different case: Fx 1.5.0.6, Java 1.5.0_07, WinXP Pro SP2, after some time or tries the browser has become unusable, only the tabs could be switched, with Tab.
(Reporter)

Comment 1

13 years ago
Posted file JRE logs from the crashes (obsolete) —
The logs under /bug353518logs/2.0/ are from 2.0 RC1; the lonely log under /bug353518logs/ is from 1.5.0.7. You can see references to 2 of them in the additional information.
Version: Trunk → 1.8 Branch
(Reporter)

Updated

13 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060919 BonEcho/2.0 Java version 1.5.0_02-b09
(Reporter)

Comment 3

13 years ago
Also crashed Opera 9.01.

Updated

13 years ago
Assignee: nobody → yuanyi21
Component: Plug-ins → Java: OJI
QA Contact: plugins → zhayupeng

Updated

13 years ago
Attachment #239370 - Attachment mime type: application/octet-stream → application/x-bzip2

Comment 4

13 years ago
Attachment #239370 - Attachment is obsolete: true

Comment 5

13 years ago
#  SIGSEGV (0xb) at pc=0xa1d8db70, pid=28407, tid=2710789040
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_08-b03 mixed mode, sharing)
# Problematic frame:
# C  [libfontmanager.so+0x2eb70]
#

---------------  T H R E A D  ---------------

Current thread (0x083d0a20):  JavaThread "AWT-EventQueue-2" [_thread_in_native, id=28433]

siginfo:si_signo=11, si_errno=0, si_code=1, si_addr=0xbc2d9fa0

Registers:
EAX=0x6d002000, EBX=0xa1dced48, ECX=0x082d1fa0, EDX=0x000000ff
ESP=0xa1934620, EBP=0xa193465c, ESI=0x082d209c, EDI=0xa19346a4
EIP=0xa1d8db70, CR2=0xbc2d9fa0, EFLAGS=0x00210296

Top of Stack: (sp=0xa1934620)
0xa1934620:   a1d89894 a19346a4 6d002000 00000000
0xa1934630:   4041fc00 62f00000 407406c6 082d6f4c
0xa1934640:   082d6f4c 082d1eb8 00000000 a1d8985b
0xa1934650:   a1dced48 a19346a4 a1dd3220 a193467c
0xa1934660:   a1d8df08 a19346a4 083fc988 00000106
0xa1934670:   4041fc00 a19346a4 082d8e38 a19347cc
0xa1934680:   a1d8d501 a19346a4 082d8e38 082d8e65
0xa1934690:   ffffffff a19346b0 a19346a4 00000400 

Instructions: (pc=0xa1d8db70)
0xa1d8db60:   55 89 e5 8b 45 08 8b 40 34 8b 48 0c 8b 45 0c 5d
0xa1d8db70:   8b 04 81 c3 8d b6 00 00 00 00 8d bf 00 00 00 00 

Stack: [0xa18b5000,0xa1936000),  sp=0xa1934620,  free space=509k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [libfontmanager.so+0x2eb70]
C  [libfontmanager.so+0x2ef08]
C  [libfontmanager.so+0x2e501]
C  [libfontmanager.so+0x30d60]
C  [libfontmanager.so+0x2f97b]
C  [libfontmanager.so+0x2f785]
C  [libfontmanager.so+0x1cb44]
C  [libfontmanager.so+0x1d072]
C  [libfontmanager.so+0x3f038]  Java_sun_font_FileFont_getGlyphImage+0x128
j  sun.font.FileFont.getGlyphImage(JI)J+0
j  sun.font.FileFontStrike.getGlyphImagePtrs([I[JI)V+92
j  sun.font.GlyphList.mapChars(Lsun/java2d/loops/FontInfo;I)Z+37
j  sun.font.GlyphList.setFromString(Lsun/java2d/loops/FontInfo;Ljava/lang/String;FF)Z+47
j  sun.java2d.pipe.GlyphListPipe.drawString(Lsun/java2d/SunGraphics2D;Ljava/lang/String;DD)V+148
j  sun.java2d.SunGraphics2D.drawString(Ljava/lang/String;II)V+25
j  com.pfsoft.proftrading.chart.ProChart.paint(Ljava/awt/Graphics;)V+592
j  com.pfsoft.proftrading.chart.ProChart.update(Ljava/awt/Graphics;)V+2
j  sun.awt.RepaintArea.updateComponent(Ljava/awt/Component;Ljava/awt/Graphics;)V+6
j  sun.awt.X11.XRepaintArea.updateComponent(Ljava/awt/Component;Ljava/awt/Graphics;)V+23
j  sun.awt.RepaintArea.paint(Ljava/lang/Object;Z)V+263
j  sun.awt.X11.XComponentPeer.handleEvent(Ljava/awt/AWTEvent;)V+188
j  java.awt.Component.dispatchEventImpl(Ljava/awt/AWTEvent;)V+765
j  java.awt.Container.dispatchEventImpl(Ljava/awt/AWTEvent;)V+42
j  java.awt.Component.dispatchEvent(Ljava/awt/AWTEvent;)V+2
j  java.awt.EventQueue.dispatchEvent(Ljava/awt/AWTEvent;)V+46
j  java.awt.EventDispatchThread.pumpOneEventForHierarchy(ILjava/awt/Component;)Z+233
j  java.awt.EventDispatchThread.pumpEventsForHierarchy(ILjava/awt/Conditional;Ljava/awt/Component;)V+26
j  java.awt.EventDispatchThread.pumpEvents(ILjava/awt/Conditional;)V+4
j  java.awt.EventDispatchThread.pumpEvents(Ljava/awt/Conditional;)V+3
j  java.awt.EventDispatchThread.run()V+9
v  ~StubRoutines::call_stub
V  [libjvm.so+0x17a75c]
V  [libjvm.so+0x28afd8]
V  [libjvm.so+0x179fb5]
V  [libjvm.so+0x17a04e]
V  [libjvm.so+0x1f1785]
V  [libjvm.so+0x2f43d3]
V  [libjvm.so+0x28bbe8]
C  [libpthread.so.0+0x5240]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  sun.font.FileFont.getGlyphImage(JI)J+0
j  sun.font.FileFontStrike.getGlyphImagePtrs([I[JI)V+92
j  sun.font.GlyphList.mapChars(Lsun/java2d/loops/FontInfo;I)Z+37
j  sun.font.GlyphList.setFromString(Lsun/java2d/loops/FontInfo;Ljava/lang/String;FF)Z+47
j  sun.java2d.pipe.GlyphListPipe.drawString(Lsun/java2d/SunGraphics2D;Ljava/lang/String;DD)V+148
j  sun.java2d.SunGraphics2D.drawString(Ljava/lang/String;II)V+25
j  com.pfsoft.proftrading.chart.ProChart.paint(Ljava/awt/Graphics;)V+592
j  com.pfsoft.proftrading.chart.ProChart.update(Ljava/awt/Graphics;)V+2
j  sun.awt.RepaintArea.updateComponent(Ljava/awt/Component;Ljava/awt/Graphics;)V+6
j  sun.awt.X11.XRepaintArea.updateComponent(Ljava/awt/Component;Ljava/awt/Graphics;)V+23
j  sun.awt.RepaintArea.paint(Ljava/lang/Object;Z)V+263
j  sun.awt.X11.XComponentPeer.handleEvent(Ljava/awt/AWTEvent;)V+188
j  java.awt.Component.dispatchEventImpl(Ljava/awt/AWTEvent;)V+765
j  java.awt.Container.dispatchEventImpl(Ljava/awt/AWTEvent;)V+42
j  java.awt.Component.dispatchEvent(Ljava/awt/AWTEvent;)V+2
j  java.awt.EventQueue.dispatchEvent(Ljava/awt/AWTEvent;)V+46
j  java.awt.EventDispatchThread.pumpOneEventForHierarchy(ILjava/awt/Component;)Z+233
j  java.awt.EventDispatchThread.pumpEventsForHierarchy(ILjava/awt/Conditional;Ljava/awt/Component;)V+26
j  java.awt.EventDispatchThread.pumpEvents(ILjava/awt/Conditional;)V+4
j  java.awt.EventDispatchThread.pumpEvents(Ljava/awt/Conditional;)V+3
j  java.awt.EventDispatchThread.run()V+9
v  ~StubRoutines::call_stub
(Reporter)

Updated

13 years ago
Blocks: 353557
(Reporter)

Comment 6

13 years ago
They've made the image version default, the Java version has been moved to http://www.forexpf.ru/_quote_show_/java/show_graph.php?q=USD&port=80

Updated

13 years ago
No longer blocks: 353557
Duplicate of this bug: 368222
(Reporter)

Comment 8

12 years ago
WFM: Both this and the dupe don't crash for me now, with new Java from Debian non-free:
Java(TM) Plug-in 1.5.0_10-b03
File name: libjavaplugin_oji.so

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0 (this one was misbehaving back then)
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060918 BonEcho/2.0

Mine doesn't seem to work, though - it says "Loading data. Please wait... Instrument: USD. Period: 1 minute."

bug 368222 reporter: could you get a newer JRE and test with it?
(Reporter)

Comment 9

12 years ago
Resolving WFM for now. If anyone still can reproduce the bug with either of the URLs, please, reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Keywords: ecommerce, qawanted
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.