Auth/Verify.pm-create_or_update_user() line 112-113 missing "undef" parameter in $dbh->do('Update...) Fails in RHEL4, MySQL4.14

RESOLVED DUPLICATE of bug 346245

Status

()

Bugzilla
Database
RESOLVED DUPLICATE of bug 346245
12 years ago
12 years ago

People

(Reporter: Phil DiMarco, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: bugzilla-2.23.2

In file Auth/Verify.pm
Function create_or_update_user() 
line 112-113 is missing an "undef" parameter when invoking
$dbh->do('UPDATE profiles SET login_name = ? WHERE userid = ?',
          $username, $user->id);
The SQL Fails in RedHatEnterpriseLinux4 using MySQL V4.14.
This bug occurs when Authenticating through LDAP only!

Reproducible: Always

Steps to Reproduce:
1.Setup LDAP connectivity to an Exchange server (ie: Tony Malandain instructions)
2.login with username only, without @domain.ext (i.e. LDAPuiattribute=samAccountName)


Actual Results:  
Software error stating that current MySQL version doesn't support 
the current syntax.


Expected Results:  
typical successful login


I manually edited file
Bugzilla/Auth/Verify.pm 
and added the missing "undef" at line 112.
This repaired the bug.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 346245 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.