Options, disable and uninstall button not available after "Find updates" without dismissing "No Updates Were Found" notification

VERIFIED FIXED in mozilla1.9alpha8

Status

()

--
minor
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: jpletzers, Assigned: rstrong)

Tracking

unspecified
mozilla1.9alpha8
Points:
---
Bug Flags:
blocking-firefox2 -
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

When you open the Add-ons manager window and hit the Find updates button it's impossible to disable or uninstall extentions before hitting the red cross in the top right corner.


Reproducible: Always

Steps to Reproduce:
1. open add-ons
2. click find updates

Actual Results:  
When you open the Add-ons manager window and hit the Find updates button it's impossible to disable or uninstall extentions before hitting the red cross in the top right corner.

Expected Results:  
Because it is only a message mentioning there are no updates availeble it should still be possible to disable or uninstall extentions. It should not be mandatory to close the popup window for only a service message
We want to display the update status of the update check in the description which is why it is required to either dismiss the notification or change the view to get this functionality back since we don't want these options available during an update check which caused a bunch of other bugs in 1.5.0.x and below. For me this is wontfix but I am going to leave it open for now to think about it a bit

Comment 2

12 years ago
Perhaps we should have some sort of visual cue to the user?  Like dimming the disabled options?
The behavior regressed recently... I'll take a look as soon as I am able to
(Reporter)

Comment 4

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2)
> Gecko/20060821 Firefox/2.0b2
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2)
> Gecko/20060821 Firefox/2.0b2
> When you open the Add-ons manager window and hit the Find updates button it's
> impossible to disable or uninstall extentions before hitting the red cross in
> the top right corner.
> Reproducible: Always
> Steps to Reproduce:
> 1. open add-ons
> 2. click find updates
> Actual Results:  
> When you open the Add-ons manager window and hit the Find updates button it's
> impossible to disable or uninstall extentions before hitting the red cross in
> the top right corner.
> Expected Results:  
> Because it is only a message mentioning there are no updates availeble it
> should still be possible to disable or uninstall extentions. It should not be
> mandatory to close the popup window for only a service message


Just for the general understanding. After the update is finished it is still impossible to use the buttons. I agree it is unwanted to have the buttons availeble during the update but after the update has finished you should be able to use them.
(Reporter)

Comment 5

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2)
> Gecko/20060821 Firefox/2.0b2
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2)
> Gecko/20060821 Firefox/2.0b2
> When you open the Add-ons manager window and hit the Find updates button it's
> impossible to disable or uninstall extentions before hitting the red cross in
> the top right corner.
> Reproducible: Always
> Steps to Reproduce:
> 1. open add-ons
> 2. click find updates
> Actual Results:  
> When you open the Add-ons manager window and hit the Find updates button it's
> impossible to disable or uninstall extentions before hitting the red cross in
> the top right corner.
> Expected Results:  
> Because it is only a message mentioning there are no updates availeble it
> should still be possible to disable or uninstall extentions. It should not be
> mandatory to close the popup window for only a service message


Just for the general understanding. After the update is finished it is still impossible to use the buttons. I agree it is unwanted to have the buttons availeble during the update but after the update has finished you should be able to use them.

Comment 6

12 years ago
If no updates are found, it seems rather redundant to leave the same "no updates" message in every single extension on the list.. or are there situations in which an extension might have a different message? (due to bad update url?)
there are other status messages besides no updates found
Status: UNCONFIRMED → NEW
Depends on: 348576
Ever confirmed: true
Keywords: regression

Updated

12 years ago
Flags: blocking-firefox2?

Comment 8

12 years ago
I'm not convinced that this is the proper bug to fix the recent regression. This bug is about putting the options/disable/uninstall buttons back if we haven't found any updates, which is separate from the issue I want to fix. Opened bug 353918 to fix the regression.
No longer depends on: 348576
Keywords: regression
Summary: Options, disable and uninstall button not availeble after "Find updates" → Options, disable and uninstall button not available after "Find updates"
Not going to block on this at this time, not clear what the right answer is, and its long past time to fix niggling little cases like this.
Flags: blocking-firefox2? → blocking-firefox2-
bug 353918 restores the previous behavior of clearing the no updates found message, update status messages, and showing the buttons when switching views. I want to have the update status messages cleared before restoring the buttons since the complexity is significantly less than trying to display both at the same time. I think the fix for this could be to simply clear the no updates found message, update status messages, and showing the buttons when selecting an item in the list.
Duplicate of this bug: 377365
beltzner, I think the normal use case is to be able to select options, disable, uninstall, etc. for add-ons after no updates are found though it would be a good thing to display the status message especially for the case where there is an error checking for updates. Perhaps a compromise where we dismiss the no updates found message and restore the buttons when a selection is made? The update status message would still be displayed when scrolling using the scrollbar so the update status message for add-ons that aren't in view can still be viewed. Not ideal but it should fix this for the normal use case.
Summary: Options, disable and uninstall button not available after "Find updates" → Options, disable and uninstall button not available after "Find updates" without dismissing "No Updates Were Found" notification
Flags: in-litmus?
Assignee: nobody → robert.bugzilla
Created attachment 279800 [details] [diff] [review]
updated patch ( implements comment #12 )
Attachment #271473 - Attachment is obsolete: true
Attachment #279800 - Flags: review?(dtownsend)
Comment on attachment 279800 [details] [diff] [review]
updated patch ( implements comment #12 )

r=me, I'm assuming beltzner or something sounded off on this?
Attachment #279800 - Flags: review?(dtownsend) → review+
I discussed this with him face to face
Checked in to trunk

Checking in mozilla/toolkit/mozapps/extensions/content/extensions.js;
/cvsroot/mozilla/toolkit/mozapps/extensions/content/extensions.js,v  <--  extensions.js
new revision: 1.148; previous revision: 1.147
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M8
Duplicate of this bug: 395126
Duplicate of this bug: 405897
Litmus triage team: tomcat will handle litmus testcase.
Verified fix on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042506 Minefield/3.0pre.  

Litmus test added: https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=5297
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus+
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.