Menu consistency: Tab-related options

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
minor
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: James Ross, Assigned: James Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.86])

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
We have the following 3 options in the IRC menu:
  Clear Tab
  Hide Tab
  Close Tab

None of these belong in "IRC" at any rate, but there is also the issue that the tab/chat context menus have this group:
  Clear Tab
  Hide Tab
  Open This <view> at Startup

I see two options:
  - Move the 3 tab options to another menu, and possibly remove the 2 from the
    context menu (or submenu them?).
  - Make the IRC menu have the same group as the context menu, effectively
    removing Close View from the UI (I think it will appear if you leave but
    don't close a channel, though).

One suggestion make on IRC (by random visitor torhu) was to have a "This view" or similar submenu to the View menu for things relating to the current view (as opposed to the rest of the menu, which should be all global).

I'm really not sure about the Open This <view> at Startup option. It's kinda IRC and it's kinda not.

/discuss
It looks like Firefox puts these on the File menu, the closest analog to that in ChatZilla is the ChatZilla menu, which is kindof bare now anyway...

Not sure if this is where it would be best, but it's certainly one possibility.

Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

9 years ago
Created attachment 394740 [details] [diff] [review]
Rearrange IRC menu to match tab/message context menus

The tab and message context menus already matched each other for these commands, so it seems logical to make the IRC menu match as well - this really just means some order changes and the addition of toggle-text-dir.
Assignee: rginda → silver
Status: NEW → ASSIGNED
Attachment #394740 - Flags: review?(gijskruitbosch+bugs)

Comment 3

9 years ago
Comment on attachment 394740 [details] [diff] [review]
Rearrange IRC menu to match tab/message context menus

r=me
Attachment #394740 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 4

9 years ago
Checked in --> FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [cz-0.9.86]

Comment 5

9 years ago
I noticed that in the previous menu item, we had
Close tab      Ctrl+W

In the new rearranged menu, we have
Leave #channel (nothing)

Is this intentional?
You need to log in before you can comment on or make changes to this bug.