If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Save Page As... saves newlines in different places

RESOLVED DUPLICATE of bug 343843

Status

()

Core
Serializers
RESOLVED DUPLICATE of bug 343843
11 years ago
11 years ago

People

(Reporter: Steve Chapel, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Reproducible: Always

Steps to Reproduce:
1. Go to https://bugzilla.mozilla.org/attachment.cgi?id=237739
2. File -> Save Page As... and click Save

Expected Results:
The file saved on the local disk matches the file sent from the server.

Actual Results:
The newlines in the file saved do not match the file sent from the server.

If you use View -> Page Source you can see where the newlines are in the file sent from the server. I can reproduce this problem in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060921 Minefield/3.0a1 and ozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060919 SeaMonkey/1.1b.

Comment 1

11 years ago
How is this networking?  As I understand it, FF saves the page as stored in memory, not as received from the server (there was a lot of discussion, I think).  So I suspect the bug is either a dupe or invalid.

Comment 2

11 years ago
Is this not a duplicate of the "contents of page saved using Save Page As don't match what's shown in View Source" bug?
Whiteboard: DUPEME

Comment 3

11 years ago
The only differences I see are at the top of the document, inside and before the HEAD element.  Seems reasonable to me that whitespace there does not make it into the DOM.
Assignee: nobody → dom-to-text
Component: Networking: File → DOM to Text Conversion
QA Contact: networking.file
I confirm this in latest nightly.
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/2006112804 Minefield/3.0a1

Comment 5

11 years ago

*** This bug has been marked as a duplicate of 343843 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.