Closed Bug 353725 Opened 13 years ago Closed 13 years ago

Infinite recurring events throw "rule.endDate has no properties" with opening the recurrence dialog

Categories

(Calendar :: Internal Components, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Sunbird 0.3

People

(Reporter: mattwillis, Assigned: mattwillis)

References

Details

(Keywords: regression)

Attachments

(1 file)

Regression from bug 351737.

Infinite recurring events throw "rule.endDate has no properties" with opening the recurrence dialog
This moves the UTC conversion inside the else, so we don't attempt it if !rule.endDate.

It also explains why this is necessary
Assignee: nobody → lilmatt
Status: NEW → ASSIGNED
Attachment #239597 - Flags: first-review?(dmose)
dmose:
How about this for a replacement comment?


rule.endDate is a floating datetime, however per RFC2445, it must be in UTC.
Since we want the datepicker to show the date based on our local timezone, we must first "pin" the floating datetime to UTC, and then convert from UTC to our local timezone. We _can't_ simply convert directly from floating to our local timezone.
Comment on attachment 239597 [details] [diff] [review]
moves the UTC conversion inside the else

r1/r2=dmose via IRC with the comment revision
Attachment #239597 - Flags: first-review?(dmose) → first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.